Bug 142374 - Error "Can't locate module block-major-43" after kernel update.
Error "Can't locate module block-major-43" after kernel update.
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Heinz Mauelshagen
Brian Brock
:
: 127310 165047 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-09 06:13 EST by Simon Hargrave
Modified: 2007-11-30 17:07 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-13 10:39:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Simon Hargrave 2004-12-09 06:13:56 EST
Description of problem:

After updating RHEL3.0 kernel to kernel-smp-2.4.21-20.0.1.EL I get 
erroneous messages on bootup: -

modprobe: modprobe: Can't locate module block-major-43.

These messages appear during the LVM startup phase.

I don't believe them to actually cause an issue (major 43 is network 
block device I believe), and I can block the messages with "alias 
block-major-43 off" in modules.conf, however this is just masking the 
problem.

Version-Release number of selected component (if applicable):

kernel-smp-2.4.21-20.0.1.EL 

How reproducible:

Happens every reboot.

Steps to Reproduce:
1. Reboot.
2.
3.
  
Actual results:

Error message on startup.

Expected results:

No error message.

Additional info:
Comment 4 Heinz Mauelshagen 2004-12-13 10:39:05 EST
There's 3 options to deal with this:

o install kernel-unsupprted which contains nbd
o stay with the workaround you have
o ignore the message
Comment 5 Heinz Mauelshagen 2004-12-15 05:26:03 EST
*** Bug 127310 has been marked as a duplicate of this bug. ***
Comment 6 Heinz Mauelshagen 2005-08-22 10:36:55 EDT
*** Bug 165047 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.