Bug 165047 - Can't locate module block-major-43
Can't locate module block-major-43
Status: CLOSED DUPLICATE of bug 142374
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Heinz Mauelshagen
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-03 16:36 EDT by Ben Levenson
Modified: 2007-11-30 17:07 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-22 10:35:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ben Levenson 2005-08-03 16:36:20 EDT
Description of problem:
This message occurs multiple times while booting 2.4.21-34.EL (RHEL-3-U6):
modprobe: modprobe: Can't locate module block-major-43

These messages do not occur on a straight-up U5 install, but they do occur with
the U5 kernel on a U6 install.  Any clue what might be going on here?

Bug 142374 (filed against 2.4.21-20.0.1.EL) was closed as NOTABUG with a
recommendation to install kernel-unsupported or to add an alias to 
modules.conf.  I realize that this will probably be closed too, but I'd
like to understand why the behavior comes and goes.  

FWIW the modprobe messages don't go away when I install kernel-unsupported.

Version-Release number of selected component (if applicable):
kernel-2.4.21-34.EL
lvm-1.0.8-14

Additional info:
LVM appears to be working properly after boot.
Comment 1 Ernie Petrides 2005-08-03 17:38:15 EDT
Hi, Ben.  I'm assigning this to Heinz due to it being related to LVM,
so he might just close this as a dup of bug 142374.  But are you sure
that you installed the 2.4.21-34.EL kernel-unsupported RPM and then
still got the errors after the reboot?

Also, do the errors come before the following console message?

  Freeing initrd memory: <n>k freed

If so, maybe you have to rebuild the initrd after installing the
kernel-unsupported RPM (if the unsupported modules are needed before
the real root file system starts being used, i.e., while the system
is still running out of the ramdisk-based initrd image).
Comment 2 Ben Levenson 2005-08-03 18:41:04 EDT
I verified that kernel-unsupported was installed and went ahead
and rebuilt initrd.  The messages are still there.  
The *do* appear after the "Freeing initrd memory" message:
Checking root filesystem: [  OK  ]
Remounting root ... in read-write mode: [  OK  ]
Setting up Logical Volume Management: modprobe: modprobe: Can't locate module block-major-43
modprobe: modprobe: Can't ...
...
(Comment posted with lynx -- sorry if formatting is bad)
Comment 3 Ernie Petrides 2005-08-05 17:02:15 EDT
Ok, thanks Ben.

I'll let Heinz follow up on this.
Comment 4 Heinz Mauelshagen 2005-08-22 10:35:55 EDT
Hrm, if this is the correct kernel-unsupported package and modules.conf, the nbd
module should get loaded fine while lvm1 is scanning for it.
If nbd is not going to be used, the message can be ignored anyway.
Closing as dup of 142374.

*** This bug has been marked as a duplicate of 142374 ***

Note You need to log in before you can comment on or make changes to this bug.