Bug 142400 - (IT_56694) 'too many open files' by LVM commands
'too many open files' by LVM commands
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: lvm2 (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alasdair Kergon
:
Depends On:
Blocks: 143501
  Show dependency treegraph
 
Reported: 2004-12-09 10:32 EST by Issue Tracker
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2005-192
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-23 11:54:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 JoAnne K. Halligan 2004-12-09 10:33:15 EST
 Version-Release number of selected component (if applicable):
  lvm2-2.00.29-1.3.RHEL4

How reproducible:
  Always

Steps to Reproduce:
  1. vgdisplay on many disks (~1000)

Actual results:
  /dev/sdafz: open filed Too many open files
  ...

Expected results:
  No warnings.

Additional info:
  Increasing the maximum number of open files by ulimit can work around this
problem.
Comment 8 Alasdair Kergon 2005-03-23 11:51:22 EST
I believe this got fixed long ago - I can't reproduce any problem like this now.
If someone provides me with enough disks I can test the precise case:-)

Note that you still need 1 file descriptor per metadata area in a volume group.
So if you had 1000 PVs in a single VG and used default settings (which would be
a rather stupid thing to do - you really don't want to maintain 999 backup
copies of your metadata - see 'man pvcreate'!) - you'd need a few more than 1000
file descriptors.
Comment 9 Tim Powers 2005-06-09 08:29:58 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-192.html

Note You need to log in before you can comment on or make changes to this bug.