Bug 143501 - Outstanding LVM2 issues affecting RHEL4 for U1
Outstanding LVM2 issues affecting RHEL4 for U1
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: lvm2 (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alasdair Kergon
:
Depends On: 112082 117316 129701 130600 138487 139420 IT_56694
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-21 13:43 EST by Alasdair Kergon
Modified: 2007-11-30 17:07 EST (History)
4 users (show)

See Also:
Fixed In Version: RHBA-2005-192
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-05 10:30:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alasdair Kergon 2004-12-21 13:43:28 EST
Created to collect together outstanding LVM2 issues affecting RHEL4.
Some were reported via email or via the Debian bug system.
Comment 1 Alasdair Kergon 2004-12-21 13:59:25 EST
Since 2.00.31 was released, I have checked the following fixes into CVS:


1. Ignore sysfs symlinks when DT_UNKNOWN.

I believe this will fix infinite loops when LVM scans sysfs on zSeries
with FCP SCSI disks.  Bug reported by Stefan Bader, IBM, (private email).


2. Skip devices that are too small to be PVs.

The debugging messages added recently cause an error message to appear
in some configurations when scanning an extended partition table -
previously no message appeared. Functionality is not affected, but the
new error message is disconcerting and may lead to unnecessary support
requests.  Reported on linux-lvm mailing list.


3. Fix pvchange -x segfault with lvm2-format orphan.

Trivial fix of no importance: lvm2 segfaulted instead of displaying an
error message.


4. Cope with empty msdos partition tables.

Several people have reported problems with the recent fixes which seem
to depend upon what was previously on their disks.  One such case has
been identified by Chris Webb (private email) who found that lilo
creates an empty partition table which is ignored by the kernel but
not by LVM2. He supplied a patch to handle this case correctly, which
I have modified slightly and applied.

Comment 4 Alasdair Kergon 2004-12-21 15:28:36 EST
5. Fix device reference counting on re-opens.

A report on linux-lvm of pvcreate looping together with a patch for
it. I've not managed to reproduce the problem, but the patch is an
extension to the recent hasty pvcreate fix so I've applied a tidied-up
version of it.
Comment 5 Alasdair Kergon 2004-12-21 16:42:05 EST
6. Fix vgdisplay -s. Breaks (undocumented) lvs/pvs/vgs -s instead for now.

Trivial. vgdisplay was treating -s as --separator, contrary to the
documentation and breaking backwards-compatibility with LVM1.
Comment 6 Alasdair Kergon 2004-12-22 17:21:30 EST
7. Fix an error fprintf.

Trivial correction to an error message.


8. Drop static/dl restriction for now.

Attempt to correct the build options so that the extensions in the
lvm2-cluster RPM will work with it - currently you have to rebuild
everything.
Comment 32 Alasdair Kergon 2005-01-05 13:53:16 EST
9 - Include read-only pool support in the build.
Comment 33 Alasdair Kergon 2005-01-05 13:55:56 EST
10 - Ensure pvcreate wipes ext superblock (bug 140329)
Comment 34 Alasdair Kergon 2005-01-05 13:58:47 EST
11 - Remove temporary /sbin symlinks: only 'lvm.static' is needed now
(everything else comes from /usr/sbin) - but must mention clearly in
release note.
Comment 35 Alasdair Kergon 2005-01-05 17:04:12 EST
12 - Make /dev/mapper logical volume permissions/ownership the same as
for disk devices so that standard backup tools are able to back up
logical volumes. (bug 141050)
Comment 37 Alasdair Kergon 2005-01-06 15:39:14 EST
13 - Transparently correct /dev/mapper/control inside libdevmapper if
it's wrong.  (bug 138487)  Included in dm 1.00.20.
Comment 38 Alasdair Kergon 2005-01-06 15:40:56 EST
Item 12 included in dm 1.00.20.
Comment 39 Alasdair Kergon 2005-01-06 15:49:09 EST
Items 9 & 11 included in 2.00.32-2.0
Comment 41 Alasdair Kergon 2005-01-11 09:12:39 EST
Item 10 included in 2.00.33.
Comment 42 Alasdair Kergon 2005-01-17 14:46:34 EST
14 - Only ask kernel for open_count when it's needed, not every time,
to improve performance & reduce risk of deadlock in some
circumstances. A kernel patch is required for this change to have any
effect.  Included in lvm2 2.01.00 / dm 1.01.00.
Comment 43 Alasdair Kergon 2005-01-17 14:56:52 EST
15 - 2 fixes so metadata auto-correction works properly again (esp. in
vgscan) - broken since May 2003!

Included in lvm2 2.01.00.
Comment 44 Alasdair Kergon 2005-01-19 12:08:05 EST
16 - vgcreate man page: qualified limitations lvm1-format only. (129701)
Comment 45 Alasdair Kergon 2005-01-19 12:24:01 EST
17 - userspace changes ready for supporting extending snapshot origin
volumes when the kernel has been fixed to handle this.
Comment 46 Alasdair Kergon 2005-02-01 12:35:58 EST
16 included in 2.01.01
17 included in 2.01.03
Comment 47 Alasdair Kergon 2005-02-01 13:01:19 EST
18 - Fail the command if generation of random id fails.
19 - Recognise gnbd devices.
20 - Tidy pool sptype_names to avoid unused const.
21 - Fix some size_t printing.

18-21 included in 2.01.02.


22 - Fixes to reporting of 64-bit sizes.
23 - Better handling of condition where /etc/lvm doesn't exist and can't be created.

22-23 included in 2.01.03.
Comment 48 Alasdair Kergon 2005-02-01 13:09:17 EST
18 meant that pvcreate would succeed if /dev/random was missing but not have a
properly-generated (or necessarily unique) PV UUID.
Comment 49 Alasdair Kergon 2005-02-01 13:14:08 EST
22 led to pvdisplay and pvs/vgs/lvs reporting incorrect sizes for TB devices in
several places (mostly 32-bit instead of 64-bit multiplication by physical
extent size).
Comment 50 Alasdair Kergon 2005-02-03 11:36:56 EST
24 - lvm2cmd.so needs to skip the check for open fds.
25 - pvmove -f option is unused: removed it.
Comment 51 Alasdair Kergon 2005-02-18 15:02:46 EST
26 - Fixed offset added to imported pool minor numbers so avoid conflicting with
already-active devices.

24-26 included in 2.01.04
Comment 52 Alasdair Kergon 2005-02-18 15:06:13 EST
27 - Reinstated the /sbin symlinks removed in item 11, but made it so they will
run the dynamic exectutable in /usr/sbin rather than the static one if it exists.

Included in 2.01.05

Note You need to log in before you can comment on or make changes to this bug.