Bug 1425063 - python-heat-agent-ansible is missing skip-tags in ansible hook
Summary: python-heat-agent-ansible is missing skip-tags in ansible hook
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-heat-agents
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: rc
: 11.0 (Ocata)
Assignee: Steve Baker
QA Contact: Amit Ugol
URL:
Whiteboard:
Depends On: 1426321
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-20 13:36 UTC by Marius Cornea
Modified: 2017-05-17 20:00 UTC (History)
14 users (show)

Fixed In Version: openstack-heat-agents-1.0.0-1.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1426321 (view as bug list)
Environment:
Last Closed: 2017-05-17 20:00:49 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC
OpenStack gerrit 424221 None None None 2017-02-20 13:36:31 UTC
OpenStack gerrit 438204 None None None 2017-02-25 20:08:46 UTC
Launchpad 1667967 None None None 2017-02-25 20:09:09 UTC

Description Marius Cornea 2017-02-20 13:36:31 UTC
Description of problem:
python-heat-agent-ansible is missing skip-tags in ansible hook. This makes it impossible to skip preupgrade validations which is required when you want to recover from a failed upgrade attempt.

Version-Release number of selected component (if applicable):
python-heat-agent-ansible-0.0.1-0.20170213135307.5705749.el7ost.noarch

How reproducible:
100%

Missing patch:
https://review.openstack.org/#/c/424221/

Workaround:
    sudo curl 'https://review.openstack.org/gitweb?p=openstack/heat-agents.git;a=blob_plain;f=heat-config-ansible/install.d/hook-ansible.py;hb=93517603eb45cb18e5503e2de1e94f68018e5d28' -o /usr/libexec/heat-config/hooks/ansible

Comment 1 Steve Linabery 2017-02-21 16:37:38 UTC
openstack-heat-templates-0.0.1-0.20170213135307.5705749.el7.centos is latest build of o-h-t and https://review.openstack.org/424221 has not landed there.

Comment 3 Mike Burns 2017-02-23 16:52:18 UTC
(In reply to Steve Linabery from comment #1)
> openstack-heat-templates-0.0.1-0.20170213135307.5705749.el7.centos is latest
> build of o-h-t and https://review.openstack.org/424221 has not landed there.

This should be resolved when we move to openstack-heat-agents instead of openstack-heat-templates.  Once bug 1426321 is complete, I expect this should be fixed.

Comment 4 Jaromir Coufal 2017-03-30 03:26:09 UTC
This is not blocker of GA, if it misses GA, we can delivery this use case as part of the z-stream.

Comment 8 errata-xmlrpc 2017-05-17 20:00:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.