Bug 1425135 - ObjectStore.cpp(59): Failed to enumerate object store in /var/lib/softhsm/tokens/
Summary: ObjectStore.cpp(59): Failed to enumerate object store in /var/lib/softhsm/tok...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: softhsm
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
Assignee: Paul Wouters
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1464490
TreeView+ depends on / blocked
 
Reported: 2017-02-20 16:12 UTC by Sami Farin
Modified: 2017-10-16 14:48 UTC (History)
7 users (show)

Fixed In Version: softhsm-2.2.0-2.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1464490 (view as bug list)
Environment:
Last Closed: 2017-07-13 14:50:14 UTC


Attachments (Terms of Use)

Description Sami Farin 2017-02-20 16:12:20 UTC
Description of problem:
each time I run wget I get two lines of spam in journal:
wget[9187]: ObjectStore.cpp(59): Failed to enumerate object store in /var/lib/softhsm/tokens/
wget[9187]: SoftHSM.cpp(476): Could not load the object store

and one line to stderr from wget:
p11-kit: softhsm: module failed to initialize, skipping: Internal error

Version-Release number of selected component (if applicable):
1.18-2

How reproducible:
100%

Steps to Reproduce:
1. wget https://bugzilla.redhat.com/
2.
3.

Actual results:
spam

Expected results:
no spam

Additional info:
p11-kit-0.23.2-2
softhsm-2.1.0-1

Comment 1 Tomáš Hozza 2017-05-12 13:35:25 UTC
Hello.

Do you use some special settings for wget? wget does not use pkcs11 nor interacts with softhsm directly, therefore this is most probably not a wget's issue.

Comment 2 Sami Farin 2017-05-12 14:22:33 UTC
~/.wgetrc is empty and no cmdline settings are used.

      2554:     file=libp11-kit.so.0 [0];  needed by /lib64/libgnutls.so.30 [0]
      2554:     file=/usr/lib64/pkcs11/p11-kit-trust.so [0];  dynamically loaded by /lib64/libp11-kit.so.0 [0]
      2554:     file=/usr/lib64/pkcs11/gnome-keyring-pkcs11.so [0];  dynamically loaded by /lib64/libp11-kit.so.0 [0]
      2554:     file=/usr/lib64/pkcs11/libsofthsm2.so [0];  dynamically loaded by /lib64/libp11-kit.so.0 [0]

So where's the issue?  Other apps using gnutls do not cause this kind of spam.

Comment 3 Nikos Mavrogiannopoulos 2017-06-22 14:09:29 UTC
I am not able to reproduce this. What are the specifics of this system and contents of /etc/softhsm2.conf? Is it is fedora system under docker, or a full fedora system?

Comment 4 Sami Farin 2017-06-22 15:58:36 UTC
Full Fedora 25, I don't know what specifics you are looking for..

# cat /etc/softhsm2.conf
# SoftHSM v2 configuration file

directories.tokendir = /var/lib/softhsm/tokens/
objectstore.backend = file

# ERROR, WARNING, INFO, DEBUG
log.level = INFO

# rpm -qf /etc/softhsm2.conf
softhsm-2.1.0-1.fc25.x86_64
# rpm -V softhsm
#

Comment 5 Sami Farin 2017-06-22 16:00:24 UTC
# l /var/lib/softhsm/tokens/
total 0
drwxrwx--- 2 ods ods  6 2016-06-22 01:29:13.000000000 +0300 .
drwxrwx--- 3 ods ods 20 2016-06-22 01:29:13.000000000 +0300 ..
#

Comment 6 Nikos Mavrogiannopoulos 2017-06-23 14:30:15 UTC
Thanks. I had the file ~/.config/softhsm2/softhsm2.conf present, that's why it was not visible. There are two issues. The first is that p11-kit is being too verbose here when a PKCS#11 module cannot be initialized, and the second is that SoftHSM is also too verbose.

I'll move the bug to these components.

Comment 7 Nikos Mavrogiannopoulos 2017-06-23 15:08:18 UTC
This most likely can be addressed by using the public tokens directory approach introduced in 2.2.0.

Comment 8 Nikos Mavrogiannopoulos 2017-06-26 11:58:59 UTC
https://github.com/opendnssec/SoftHSMv2/pull/330

Comment 9 Fedora Update System 2017-06-27 06:23:47 UTC
softhsm-2.2.0-2.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-12359c53e8

Comment 10 Fedora Update System 2017-06-27 06:24:11 UTC
softhsm-2.2.0-2.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-30c570630b

Comment 11 Fedora Update System 2017-06-27 17:26:16 UTC
softhsm-2.2.0-2.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-30c570630b

Comment 12 Fedora Update System 2017-06-27 20:25:58 UTC
softhsm-2.2.0-2.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-12359c53e8

Comment 13 Fedora Update System 2017-06-29 16:42:20 UTC
freeipa-4.4.4-4.fc25 softhsm-2.2.0-2.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-30c570630b

Comment 14 Fedora Update System 2017-06-29 16:54:19 UTC
freeipa-4.4.4-4.fc26 softhsm-2.2.0-2.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-12359c53e8

Comment 15 Fedora Update System 2017-06-30 02:24:55 UTC
freeipa-4.4.4-4.fc25, softhsm-2.2.0-2.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-30c570630b

Comment 16 Fedora Update System 2017-06-30 20:24:53 UTC
freeipa-4.4.4-4.fc26, softhsm-2.2.0-2.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-12359c53e8

Comment 17 Fedora Update System 2017-07-13 14:50:14 UTC
freeipa-4.4.4-4.fc26, softhsm-2.2.0-2.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.