Bug 1464490 - ObjectStore.cpp(59): Failed to enumerate object store in /var/lib/softhsm/tokens/
ObjectStore.cpp(59): Failed to enumerate object store in /var/lib/softhsm/tok...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: p11-kit (Show other bugs)
25
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Daiki Ueno
Fedora Extras Quality Assurance
:
Depends On: 1425135
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-23 10:33 EDT by Nikos Mavrogiannopoulos
Modified: 2017-08-29 16:24 EDT (History)
11 users (show)

See Also:
Fixed In Version: p11-kit-0.23.8-1.fc25
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1425135
Environment:
Last Closed: 2017-08-29 16:24:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nikos Mavrogiannopoulos 2017-06-23 10:33:57 EDT
+++ This bug was initially created as a clone of Bug #1425135 +++

Description of problem:
each time I run wget I get two lines of spam in journal:
wget[9187]: ObjectStore.cpp(59): Failed to enumerate object store in /var/lib/softhsm/tokens/
wget[9187]: SoftHSM.cpp(476): Could not load the object store

and one line to stderr from wget:
p11-kit: softhsm: module failed to initialize, skipping: Internal error

Version-Release number of selected component (if applicable):
1.18-2

How reproducible:
100%

Steps to Reproduce:
1. wget https://bugzilla.redhat.com/
2.
3.

Actual results:
spam

Expected results:
no spam

Additional info:
p11-kit-0.23.2-2
softhsm-2.1.0-1

--- Additional comment from Tomáš Hozza on 2017-05-12 09:35:25 EDT ---

Hello.

Do you use some special settings for wget? wget does not use pkcs11 nor interacts with softhsm directly, therefore this is most probably not a wget's issue.

--- Additional comment from Sami Farin on 2017-05-12 10:22:33 EDT ---

~/.wgetrc is empty and no cmdline settings are used.

      2554:     file=libp11-kit.so.0 [0];  needed by /lib64/libgnutls.so.30 [0]
      2554:     file=/usr/lib64/pkcs11/p11-kit-trust.so [0];  dynamically loaded by /lib64/libp11-kit.so.0 [0]
      2554:     file=/usr/lib64/pkcs11/gnome-keyring-pkcs11.so [0];  dynamically loaded by /lib64/libp11-kit.so.0 [0]
      2554:     file=/usr/lib64/pkcs11/libsofthsm2.so [0];  dynamically loaded by /lib64/libp11-kit.so.0 [0]

So where's the issue?  Other apps using gnutls do not cause this kind of spam.

--- Additional comment from Nikos Mavrogiannopoulos on 2017-06-22 10:09:29 EDT ---

I am not able to reproduce this. What are the specifics of this system and contents of /etc/softhsm2.conf? Is it is fedora system under docker, or a full fedora system?

--- Additional comment from Sami Farin on 2017-06-22 11:58:36 EDT ---

Full Fedora 25, I don't know what specifics you are looking for..

# cat /etc/softhsm2.conf
# SoftHSM v2 configuration file

directories.tokendir = /var/lib/softhsm/tokens/
objectstore.backend = file

# ERROR, WARNING, INFO, DEBUG
log.level = INFO

# rpm -qf /etc/softhsm2.conf
softhsm-2.1.0-1.fc25.x86_64
# rpm -V softhsm
#

--- Additional comment from Sami Farin on 2017-06-22 12:00:24 EDT ---

# l /var/lib/softhsm/tokens/
total 0
drwxrwx--- 2 ods ods  6 2016-06-22 01:29:13.000000000 +0300 .
drwxrwx--- 3 ods ods 20 2016-06-22 01:29:13.000000000 +0300 ..
#

--- Additional comment from Nikos Mavrogiannopoulos on 2017-06-23 10:30:15 EDT ---

Thanks. I had the file ~/.config/softhsm2/softhsm2.conf present, that's why it was not visible. There are two issues. The first is that p11-kit is being too verbose here when a PKCS#11 module cannot be initialized, and the second is that SoftHSM is also too verbose.

I'll move the bug to these components.
Comment 1 Nikos Mavrogiannopoulos 2017-06-23 10:36:36 EDT
https://github.com/p11-glue/p11-kit/pull/84
Comment 2 Nikos Mavrogiannopoulos 2017-06-23 11:07:14 EDT
The upstream patch addresses the issue.
Comment 3 Sami Farin 2017-06-23 11:23:26 EDT
Thanks. Pull request 84 prevents stderr logs, but I still get the two systemd journal log lines.
Comment 4 Nikos Mavrogiannopoulos 2017-06-26 02:55:07 EDT
These should be addressed on softhsm itself.
Comment 5 Fedora Update System 2017-08-25 09:42:57 EDT
p11-kit-0.23.8-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-bd0324f3e9
Comment 6 Fedora Update System 2017-08-29 16:24:56 EDT
p11-kit-0.23.8-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.