Bug 1426058 - [RFE] request to provide option "--password" for virt-who-password command
Summary: [RFE] request to provide option "--password" for virt-who-password command
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-who
Version: 7.4
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Chris Snyder
QA Contact: Eko
Yehuda Zimmerman
URL:
Whiteboard:
: 1406721 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-23 06:46 UTC by Eko
Modified: 2017-08-01 19:24 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Password options added to *virt-who-password* With this update, the "-p" and "--password" options have been added to the *virt-who-password* utility. This enables the utility to be used in scripts.
Clone Of:
Environment:
Last Closed: 2017-08-01 19:24:47 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2084 normal SHIPPED_LIVE virt-who bug fix and enhancement update 2017-08-01 18:14:28 UTC

Description Eko 2017-02-23 06:46:16 UTC
Description of problem:
some customers want to use virt-who-password in their scripts, but it doesn't support interact, no "-p" or "--password" options, 

please refer to this commit by Marek: 
https://github.com/virt-who/virt-who/commit/5f49a9febd9fc6109afa0250e31bd5efcfecd8e9


Steps to Reproduce:
1.  run virt-who-password with --password or -p
# virt-who-password --password admin
Password:

Comment 2 Eko 2017-03-15 02:11:20 UTC
*** Bug 1406721 has been marked as a duplicate of this bug. ***

Comment 3 Eko 2017-03-28 05:09:29 UTC
it's fixed in virt-who-0.19-1, should change the status to ON_QA and add it to errata list.


# virt-who-password --help
Usage: virt-who-password

Utility that encrypts passwords for virt-who.

Enter password that should be encrypted. This encrypted password then can be
supplied to virt-who configuration.

This command must be executed as root!

WARNING: root user can still decrypt encrypted passwords!
    
Options:
  -h, --help            show this help message and exit
  -p PASSWORD, --password=PASSWORD
                        Password

Comment 6 errata-xmlrpc 2017-08-01 19:24:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2084


Note You need to log in before you can comment on or make changes to this bug.