Note: This bug is displayed in read-only format because
the product is no longer active in Red Hat Bugzilla.
Red Hat Satellite engineering is moving the tracking of its product development work on Satellite to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "Satellite project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs will be migrated starting at the end of May. If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "Satellite project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/SAT-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Description of problem:
While deploying vms on the VMWare via satellite, the satellite server pull all the networks from all clusters, if there are multiple clusters having same network name, the VM it get associated with the wrong cluster and the build fails with error:
A specified parameter was not correct. spec.deviceChange.device.port.switchUuid
Version-Release number of selected component (if applicable):
Satellite v 6.2.7
How reproducible:
At customer end.
Steps to Reproduce:
1. Setup multiple clusters on the VMWare, while creating networks under the clusters create them with same name.
2. Try to provision a vm on VMWare from the satellite server with one cluster
Actual results:
Vm get associated with the wrong cluster and provisioning fails with error ->
A specified parameter was not correct. spec.deviceChange.device.port.switchUuid
Expected results:
While deploying VM, satellite server should query the only selected clusters instead all clusters.
Additional info:
Similar issue was reported to upstream project in past but it is closed without resolution: http://projects.theforeman.org/issues/2188
Thanks Matt, it looks like a duplicate.
I'm closing this issue, if I misunderstood it, please let me know or reopen it.
*** This bug has been marked as a duplicate of bug 1426592 ***