Bug 1426592 - VMware provisioning displays all IP address
Summary: VMware provisioning displays all IP address
Status: CLOSED DUPLICATE of bug 1489516
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Compute Resources - VMWare
Version: 6.2.7
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Lukáš Hellebrandt
URL: https://projects.theforeman.org/issue...
Whiteboard:
Keywords: Triaged
: 1426069 (view as bug list)
Depends On:
Blocks: 1620176
TreeView+ depends on / blocked
 
Reported: 2017-02-24 12:16 UTC by maneesh verma
Modified: 2019-06-04 09:39 UTC (History)
13 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2019-06-04 09:39:45 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 19424 None None None 2017-04-28 11:09 UTC

Description maneesh verma 2017-02-24 12:16:31 UTC
Description of problem:

When doing provisioning using vmware, after selecting the cluster it shows all the ip addresses which are on vsphere.

How reproducible:

Whenever doing provisioning using VMware as deployment machine.

Steps to Reproduce:

Go to new host, start the provisioning, select the deploy on Vmware and then select Vmware cluster, in interface tab it shows all the IP address.

Actual results:

It should display network which are part of selected cluster
Expected results:
Displaying networks from all cluster which are in Vsphere environment.

Additional info:

Comment 4 Marek Hulan 2017-04-28 11:05:36 UTC
*** Bug 1426069 has been marked as a duplicate of this bug. ***

Comment 5 Marek Hulan 2017-04-28 11:09:43 UTC
Created redmine issue http://projects.theforeman.org/issues/19424 from this bug

Comment 6 Matt Ruzicka 2017-08-23 13:13:58 UTC
vaguely related BZ 1218628 (Ability to search VmWare networks) has moved to verified for 6.3, but that BZ doesn't solve the use case of multiple networks across clusters with the same name. Example:

cluster 1:

VLAN_100
VLAN_101
VLAN_102

cluster 2:

VLAN_100
VLAN_101
VLAN_102

cluster 3:

VLAN_100
VLAN_101
VLAN_102

The new search function (which will be a nice addition) does not appear to solve for the above use case. It seems if they would search for "VLAN_100" they would get 3 seemingly identical networks without an understand of which is for the cluster they are deploying to. Unless there is other logic change to only display those networks on the specific cluster.

Comment 9 maneesh verma 2017-09-25 08:39:12 UTC
At the time of provisioning, when we select a specific cluster, Satellite displays the IP address of all the clusters, but it should display only one cluster IP's.

Comment 20 Marek Hulan 2019-05-24 19:22:00 UTC
Ondrej, is this fixed by your recent change to how we load resources?

Comment 22 Ondřej Ezr 2019-06-04 09:37:32 UTC
Yeah, this is fixed in 6.6 and now works as described.

Comment 23 Ondřej Ezr 2019-06-04 09:39:45 UTC
Marking as duplicate, as it is solved as part of marked BZ.

*** This bug has been marked as a duplicate of bug 1489516 ***


Note You need to log in before you can comment on or make changes to this bug.