Bug 142630 - [patch]Subscript shortcut key does not work.
Summary: [patch]Subscript shortcut key does not work.
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org   
(Show other bugs)
Version: 3
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
Keywords:
: 148031 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-11 02:13 UTC by Jeremy Scheff
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-21 12:02:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vcl patch (1.05 KB, patch)
2004-12-15 11:37 UTC, Caolan McNamara
no flags Details | Diff
move the writer accelerators (2.75 KB, patch)
2004-12-15 11:57 UTC, Caolan McNamara
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 39031 None None None Never

Description Jeremy Scheff 2004-12-11 02:13:44 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041020 Epiphany/1.4.4

Description of problem:
In openoffice.org writer, you are supposed to be able to highlight
text and press CTRL+SHIFT+B to make it a subscript.  It worked fine in
the openoffice.org included in fc2, but in fc3, instead of making a
subscript, it turns the character into what first looks like an
underlined capital B and then changes to a space.  Superscript
(CTRL+SHIFT+P) works fine.

Version-Release number of selected component (if applicable):
openoffice.org-1.1.2-11.5.fc3

How reproducible:
Always

Steps to Reproduce:
1. Open openoffice.org writer and type something in it.
2. Highlight some text and press CTRL+SHIFT+B
    

Actual Results:  It turns the text into what first looks like an
underlined capital B and then changes to a space.

Expected Results:  The text should be a subscript.

Additional info:

Comment 1 Caolan McNamara 2004-12-15 09:58:50 UTC
The same thing happens in gnome-terminal. Apparently once ctrl-shift
are held down in X unicode input is enabled, so digits 0-9 and A-F are
trapped, allowing you to input the hex code for a letter. e.g.
ctrl-shift + 5 + 6 gives an underlined 56 while typed and a final V
when released.

Perhaps OOo should change the keyboard shortcuts to disallow
ctrl-shift A-F, it disallows ctrl-shift 0-9 already

Comment 2 Caolan McNamara 2004-12-15 11:37:46 UTC
Created attachment 108599 [details]
vcl patch

reserve ctrl-shift-A-F

Comment 3 Caolan McNamara 2004-12-15 11:57:08 UTC
Created attachment 108600 [details]
move the writer accelerators

i.e. ctrl-shift-H for superscript and ctrl-shift-L for subscript (high/low)

Comment 4 Caolan McNamara 2004-12-15 12:01:09 UTC
Upstreamed as http://www.openoffice.org/issues/show_bug.cgi?id=39031

Comment 5 Caolan McNamara 2005-02-16 13:04:05 UTC
*** Bug 148031 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.