Bug 14268 - default hdparm settings cause SEVERE HARDDISK CORRUPTION
Summary: default hdparm settings cause SEVERE HARDDISK CORRUPTION
Status: CLOSED DUPLICATE of bug 13730
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: hdparm   
(Show other bugs)
Version: 7.1
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-07-19 06:52 UTC by Hans de Goede
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-19 19:17:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Hans de Goede 2000-07-19 06:52:34 UTC
After installing beta3 on an old 486 laptop and playing around a bit the
entire install started falling apart. Every sector touched (even if just to
update the last access time) was corrupted.

I was totally shocked. This is so BAD I don't have any words for it. Why
are there any settings enabled by default in /etc/sysconfig/harddisks, if
this was safe don't you think the kernel would enable them by default
itself?

The enabling of 32bit io + lookahead hoses the toshiba hd in this toshiba
laptop for sure.

Please fix this ASAP, preferrably before beta4 and absolutly for beta5.

Possible fixes: don't put anything enabled in /etc/sysconfig/harddisks
and/or rename /etc/sysconfig/harddisks to /etc/sysconfig/harddisks.example

Also having one setting for all HD's is bad IMHO, but this is more a
initscripts bug.

Comment 1 Hans de Goede 2000-07-19 12:00:11 UTC
Just saw that 32bit_io is already turned of according to bug 13730 , could you
also please turn the look ahead of to be sure. (I haven't tried which one
actually causes the problem)



Comment 2 Bill Nottingham 2000-07-19 15:37:21 UTC

*** This bug has been marked as a duplicate of 13730 ***

Comment 3 Hans de Goede 2000-07-19 19:16:59 UTC
Please note that that bug only talks about the 32bit io, while read_ahead is
also enabled by default. Is this disabled (or left as the kernel has set it) by
default now too?


Comment 4 Bernhard Rosenkraenzer 2000-07-19 19:25:34 UTC
done.


Note You need to log in before you can comment on or make changes to this bug.