Bug 142691 - Make hangs with large values of parallel jobs (-j)
Summary: Make hangs with large values of parallel jobs (-j)
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: make
Version: 3
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
: 17374 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-12 23:00 UTC by John William
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version: 3.80-6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-12-13 21:27:25 UTC


Attachments (Terms of Use)

Description John William 2004-12-12 23:00:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; 
Q312461)

Description of problem:
Passing make a large number of jobs, either as "-j n" or as "--
jobs==n" will hang make for large values of "n". The magic number 
appears to be 4098 on my test system. "make -j 4097" works 
correctly. "make -j 4098" hangs.

Note that make itself hangs - this isn't a problem with trying to 
spawn too many processes. Make will hang even when all targets are up-
to-date.

This bug has been present since at least RH6.2

Version-Release number of selected component (if applicable):
make-3.80-5

How reproducible:
Always

Steps to Reproduce:
1. "make -j 9999" - make hangs.
2.
3.
    

Actual Results:  Make hangs.

Expected Results:  Make should either give an error message, use a 
smaller value for -j with a warning or work correctly.

Additional info:

Comment 1 John William 2004-12-12 23:00:45 UTC
*** Bug 17374 has been marked as a duplicate of this bug. ***

Comment 2 Jakub Jelinek 2004-12-13 21:27:25 UTC
Well, it hurts, then don't do it ;)
Anyway, make-3.80-6 in tomorrow's rawhide should disregard -jN for N bigger
than PIPE_BUF.


Note You need to log in before you can comment on or make changes to this bug.