Bug 17374 - Make hangs with large values of parallel jobs
Make hangs with large values of parallel jobs
Status: CLOSED DUPLICATE of bug 142691
Product: Red Hat Linux
Classification: Retired
Component: make (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-09-09 01:17 EDT by John William
Modified: 2007-04-18 12:28 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:47:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John William 2000-09-09 01:17:26 EDT
Standard RH6.2 distro with make-3.78.1-4.

Passing make a large number of jobs, either as "-j n" or as "--jobs==n" 
will hang make for large values of "n". The magic number appears to be 
4098 on my test system. "make -j 4097" works correctly. "make -j 4098" 
hangs.

Note that make itself hangs - this isn't a problem with trying to spawn 
too many processes. Make will hang even when all targets are up-to-date.
Comment 1 Bill Nottingham 2000-09-12 19:04:05 EDT
It fills up the pipe it uses (one character from each job, 4096
byte standard pipe buffer.)
Comment 2 Alan Cox 2002-12-14 20:39:23 EST
Still present in 8.0 - make should be erroring this
Comment 3 John William 2004-12-12 18:00:38 EST

*** This bug has been marked as a duplicate of 142691 ***
Comment 4 Red Hat Bugzilla 2006-02-21 13:47:45 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.