Bug 142692 - tmscsim driver not included/not recognizing AM53C974 chipset
tmscsim driver not included/not recognizing AM53C974 chipset
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-12 18:15 EST by John William
Modified: 2015-01-04 17:13 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-02 16:49:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John William 2004-12-12 18:15:03 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; 
Q312461)

Description of problem:
On a SCSI-only machine, with onboard AM53C974 SCSI, none of the FC3 
boot images recognize the SCSI controller. While the tmscisim driver 
is included in the normal kernel install, I cannot tell if the initrd 
for the normal boot options omits this driver or if the tmscsim 
driver is not being loaded or does not recognize the chipset.

/sbin/lspci output for the device is:

00:04.0 SCSI storage controller: Advanced Micro Devices [AMD] 53c974 
[PCscsi] (rev 02)
        Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- 
ParErr+ Stepping+ SERR+ FastB2B-
        Status: Cap- 66Mhz- UDF- FastB2B- ParErr+ DEVSEL=medium 
>TAbort- <TAbort- <MAbort- >SERR- <PERR+
        Latency: 0
        Interrupt: pin A routed to IRQ 10
        Region 0: I/O ports at ff00 [size=128]


Version-Release number of selected component (if applicable):
Kernel included with rescue CD, bootdisk.img, FC3 CD #1

How reproducible:
Always

Steps to Reproduce:
1. Try to boot machine with diskboot.img, rescue CD or CD #1
2. With no SCSI driver, cannot access CD or HD image.

Actual Results:  Cannot continue install.

Expected Results:  Should find and load tmscsim driver and recognize 
CD and HD.

Additional info: Similar to (same as?) bug 123616.
Comment 1 Dave Jones 2004-12-12 18:21:12 EST
does it work if you boot with 'noprobe', and select it manually ?
(It may be labelled 'dc390t')
the tmscsim driver should be built, and present in the initrd.
Comment 2 John William 2004-12-13 19:29:27 EST
I can't find it, or anything else that looks promising, on the list. 
Certainly no Tekram, DC390 or tmscsim.
Comment 3 Dave Jones 2004-12-13 19:30:18 EST
jeremy, is this something missing from anaconda ?
Comment 4 Jeremy Katz 2004-12-13 20:42:58 EST
Yeah, wasn't in the kernel when I did a purge of old drivers, hence it
got nuked from the list I include.  Added back.
Comment 5 John William 2005-01-08 12:38:51 EST
I just tested the Jan 8 development snapshot, and now diskboot.img 
locks the machine up (sigh) and the isolinux version still does not 
have the tmscsim driver included. Were the changes incorporated into 
this version?
Comment 6 Dave Jones 2005-01-11 00:11:00 EST
todays tree should be somewhat better. The kernel module is definitly being
built, so anaconda *should* be picking it up now too.
Comment 7 John William 2005-01-15 11:08:21 EST
I tried the January 14th snapshot, and got the following:

Booting from diskboot.img, I get to the SYSLINUX prompt and 
get "Could not find kernel image: linux".

Booting from the isolinux directory, I get a kernel panic - "no init 
found".

Since the machine I'm using cannot boot from CDROM, I copy the files 
onto the HD and use memdisk, called from GRUB, to get the machine 
going.

Note You need to log in before you can comment on or make changes to this bug.