Bug 142698 - system-config-printer crashes when using an imported PPD file
system-config-printer crashes when using an imported PPD file
Status: CLOSED DUPLICATE of bug 132625
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-12 20:11 EST by David Kaplan
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-13 10:48:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ppd that causes problem (75.71 KB, text/plain)
2004-12-12 20:11 EST, David Kaplan
no flags Details

  None (edit)
Description David Kaplan 2004-12-12 20:11:18 EST
Description of problem:
I imported HP's PPD for its 4550 color laserjet printer into
system-config-printer.  After restart, I went to change the driver for
one of my printers to the new ppd.  I selected what I think is the
imported driver (it says "Color Laserjet 4550 (PPD)") and then asked
to see the driver notes.  Upon doing so, it throws an error (shown
below).  I then went to apply the changes and system-config-printer
just hangs after muttering something about iteration over
non-sequence.  This hang occurs even if I don't try to look at notes
first.

Trying to use this driver with a new printer (i.e. not modifying an
old one) allows you to add the printer and prints a test page, but
hangs when you try to change the settings.

Also, one of my printers that was originally created with the cups web
based administrator appears as a "Browsed queue" and is uneditable. 
What is a browsed queue and why is this one uneditable but the others
are editable?

The error messages when I try to use the PPD are below:

# system-config-printer
Traceback (most recent call last):
  File "/usr/share/printconf/util/editQueue.py", line 901, in
notes_button_clicked
    self.parent.show_notes (printer_id, driver, self)
  File "/usr/share/printconf/util/queueTree.py", line 768, in show_notes
    source1 += notes.printer_comments_dict.get ("en", "")
AttributeError: 'NoneType' object has no attribute 'printer_comments_dict'
Couldn't load driver information.
Traceback (most recent call last):
  File "/usr/share/printconf/util/queueTree.py", line 600, in
edit_button_clicked
    if self.editQueue.editQueueDialog (iter):
  File "/usr/share/printconf/util/editQueue.py", line 448, in
editQueueDialog
    self.write_driver_options ()
  File "/usr/share/printconf/util/editQueue.py", line 922, in
write_driver_options
    for option_tuple in option_list:
TypeError: iteration over non-sequence


Version-Release number of selected component (if applicable):
system-config-printer-0.6.116-1

How reproducible:
always

Steps to Reproduce:
1.import PPD
2.change driver of a printer to the imported PPD 
3.accept changes
  
Actual results:
hangs

Expected results:
should use driver for printer

Additional info:
Is it really necessary for system-config-printer to be incompatible
with the cups web based administration tool?  This seems like a bad
direction.  The web based adminstration tool is rock solid and
compatibility with it should be a priority.

Also, if it can't be compatible, then at the very least it shouldn't
destroy printer configurations made elsewhere without at least asking
first.  For me, starting system-config-printers completely changes
settings and makes for an unuseable printer.
Comment 1 David Kaplan 2004-12-12 20:11:49 EST
Created attachment 108415 [details]
ppd that causes problem
Comment 2 Tim Waugh 2004-12-13 10:48:19 EST
This has been fixed in rawhide, and the fix will be included in any future
foomatic update for FC-3 we issue.

*** This bug has been marked as a duplicate of 132625 ***
Comment 3 David Kaplan 2004-12-13 15:16:02 EST
Is it really necessary for system-config-printer to be incompatible
with the cups web based administration tool?  This seems like a bad
direction.  The web based adminstration tool is rock solid and
compatibility with it should be a priority.

Also, if it can't be compatible, then at the very least it shouldn't
destroy printer configurations made elsewhere without at least asking
first.  For me, starting system-config-printers completely changes
settings and makes for an unuseable printer.
Comment 4 David Kaplan 2004-12-13 15:21:03 EST
Also, one of my printers that was originally created with the cups web
based administrator appears as a "Browsed queue" and is uneditable. 
What is a browsed queue and why is this one uneditable but the others
are editable?


Note You need to log in before you can comment on or make changes to this bug.