Bug 142715 - All screensavers in KDE except Random produce blank screens
Summary: All screensavers in KDE except Random produce blank screens
Status: CLOSED DUPLICATE of bug 138655
Alias: None
Product: Fedora
Classification: Fedora
Component: xscreensaver   
(Show other bugs)
Version: 3
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-13 09:47 UTC by Christopher Hansen
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-03 15:38:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Christopher Hansen 2004-12-13 09:47:44 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041020
Firefox/0.10.1

Description of problem:
Whenever I select a screensaver in KDE (except Random) all it produces
is a blank screen. Random works perfectly but none of the others do.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Choose screensaver other than Random in Control Centre.
2. Lock Session or wait for time period to elapse.  

Actual Results:  Blank Screen

Expected Results:  Desired Screensaver

Additional info:

Comment 1 Sitsofe Wheeler 2004-12-13 18:33:37 UTC
Possibly related to bug #138655#c5 (no idea though since we don't know the RPM
version number of xscreensaver installed)

Comment 2 Mark Stier 2005-01-18 10:54:16 UTC
Must be trivial to solve: some people reported that downgrading the
package to FC2 solves the problem...

Comment 3 Jim J 2005-01-20 15:52:15 UTC
There is a detailed discussion of this problem on the Fedoraforum.org
site as it relates specifically to the use of xscreensavers under KDE.
 You can read the posts here:
http://www.fedoraforum.org/forum/showthread.php?p=139349

It appears that all native KDE screensavers (those with the .kss
extension) work under KDE.  The Random screensaver will work when it
launches native KDE screensavers, but it will only show blank
screensavers when accessing non-native (ie xscreensaver) screen
savers.    

ALL screensavers work under gnome.

The guess is that there is a problem with the xscreensaver.kss file or
with the configuration files for xscreensaver.kss.

It appears that downgrading the package to a Fedora Core 2 version
fixes some of the problems.  

Comment 4 Jamie Zawinski 2005-02-28 03:43:31 UTC
The only sensible way to use the xscreensaver display modes under KDE is to
disable the built-in KDE screen saver and actually run xscreensaver.

See FAQ: http://www.jwz.org/xscreensaver/faq.html#kde

The xscreensaver.kss file has been removed as of xscreensaver 4.20, because I
was told that KDE no longer uses it by default.

Comment 5 Ray Strode [halfline] 2005-06-03 15:38:20 UTC

*** This bug has been marked as a duplicate of 138655 ***


Note You need to log in before you can comment on or make changes to this bug.