Bug 138655 - xscreensaver screensavers don't work in kde
xscreensaver screensavers don't work in kde
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xscreensaver (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
: 142443 142715 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-10 10:19 EST by Ventsislav Genchev
Modified: 2007-11-30 17:10 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-06 12:08:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ventsislav Genchev 2004-11-10 10:19:23 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041020

Description of problem:
The configured Screed Saver does not show up when the session is locked.
I've tried this with The matrix and star wars screen savers.. 

Version-Release number of selected component (if applicable):
kdebase-3.3.1-4.1

How reproducible:
Always

Steps to Reproduce:
1. Choose your screen saver
2. Save it
3. Lock your session
    

Actual Results:  black screen... no screen saver is engaged

Expected Results:  the select screen saver should appear.. 

Additional info:

I hadn't tried this with the kde originally packaged in FC3 ..
kdebase-3.3.1-4.1 is the update after the release..
Comment 1 Miles Sabin 2004-11-20 18:07:58 EST
Ditto, on both an FC3 and a rawhide machine. In both cases the savers
function perfectly when invoked via the 'Test' button in KDE's Screen
Saver Setting dialog. On the FC3 machine I see,

X error in halftone:
X Error of failed request:  BadWindow (invalid Window parameter)
  Major opcode of failed request:  3 (X_GetWindowAttributes)
  Resource id in failed request:  0x7
  Serial number of failed request:  187
  Current serial number in output stream:  188

in .xsession-errors when the screen saver (halftone in this case)
tries to kick in.
Comment 2 Chris Jones 2004-11-24 18:00:11 EST
I also have this problem on serial FC3 boxes. 

However, I have the problem even if I don't lock the screen. On one
box the screen saver *never* works, on another only a blank screen
kicks in after the correct time internal. 

Both work fine in gnome.

This bug is also discussed in over places, such as the KDE bug pages, e.g.
http://bugs.kde.org/show_bug.cgi?id=88649

Comment 3 Ngo Than 2004-11-26 15:40:47 EST
it is a bug in xscreensaver. which caused this problem. I have now
added a fix in xscreensaver-4.18-13, which will fix the problem. It
will show up in rawhide soon. Thanks for your report.
Comment 4 Miles Sabin 2004-12-04 11:07:33 EST
I've just updated to xscreensaver-{base,extras,gl-extras}-4.18-14 on
rawhide, and the problem still seems to be present.

In the KDE Configure Desktop - Screen Saver dialog, almost none of the
screensavers are functional (I've found a couple of exceptions:
banner and blob, there might be others), in the preview, when hitting
the Test button, and when locking the screen.

On rawhide I don't get any kind of error report in .xsession-errors: is
there any other information I can provide which would help resolve this?
Comment 5 Ngo Than 2004-12-04 11:58:58 EST
Ray,

i have noticed that you have changed the screen_hack_dir in 4.18-14
release. This change has caused that the kde screensaver does not
work anymore, because it looks the in old path
/usr/X11R6/lib/xscreensaver.

Is it intended to change the screen_hack_dir to
%{_libexecdir}/xscreensaver/hacks ?

i now assign the bug 138655 to you. It would be nice if you could make
a fc3 update for this!

Comment 6 Ngo Than 2004-12-10 17:48:47 EST
*** Bug 142443 has been marked as a duplicate of this bug. ***
Comment 7 Ray Strode [halfline] 2005-06-03 11:38:28 EDT
*** Bug 142715 has been marked as a duplicate of this bug. ***
Comment 8 Ray Strode [halfline] 2005-06-03 11:49:56 EDT
So just to make it clear, the problem is xscreensaver.kss that used to ship with
xscreensaver had some weird assumptions about the location of screensavers that
broke when I changed where screensavers got installed.

Newer versions of xscreensaver don't ship with xscreensaver.kss anymore, so this
is really only a bug for fc3/rhel4.
Comment 9 Colleen Beamer 2005-07-01 19:32:12 EDT
I can't get xscreensavers to work when using the KDE desktop in Fedora Core 4
either.  I have installed the packages xscreensaver-extras and
xscreensaver-gl-extras and they still don't work.  It's not that I don't have
screensavers, but I want the same screensavers that I had in FC3 and I don't
understand why this isn't possible!

My packages are all up to date. I've looked on fedora-list for solutions and the
and I am unable to get one that was provided to work.  I'm getting really
frustrated with this!  I don't understand why the Fedora project can't package
the screensavers the same way they were packaged in FC3.
Comment 10 Ray Strode [halfline] 2005-07-02 00:37:13 EDT
Hi Colleen,

xscreensaver display modes don't work in KDE in FC4 because the upstream
xscreensaver package no longer supports that configuration.  It used to ship a
program (xscreensaver.kss) that would plug into the kde screensaver framework to
enable its screensavers to work, but it no longer does for various reasons.

Comment 11 Colleen Beamer 2005-07-02 19:40:15 EDT
(In reply to comment #10)
> Hi Colleen,
> 
> xscreensaver display modes don't work in KDE in FC4 because the upstream
> xscreensaver package no longer supports that configuration.  It used to ship a
> program (xscreensaver.kss) that would plug into the kde screensaver framework to
> enable its screensavers to work, but it no longer does for various reasons.
> 
> 
Thanks for the response.  Not a response I was hoping for :-), but at least a
direct one that doesn't beat around the bush.

That said, I still miss the screensavers that I had in FC3.  I realize the
developers have more important things to concern themselves with, but are there
ever going to be the multitude that there were in FC3?
Comment 12 Ray Strode [halfline] 2005-07-05 10:13:36 EDT
Hi again,
There aren't currently any plans to invest development time in implementing more
screensavers for KDE in Fedora Core.  You might be able to turn off the
screensaver program KDE uses and turn on xscreensaver, however.

Alternatively, if you don't mind GNOME, it uses xscreensaver by default.
Comment 13 Ventsislav Genchev 2005-07-05 10:15:00 EDT
kdeartwork 3.4.1-0.fc4.2 corrects the issue with those screeensavers... 

Enjoy them Colleen :) 
Comment 14 Colleen Beamer 2005-07-05 18:02:50 EDT
(In reply to comment #13)
> kdeartwork 3.4.1-0.fc4.2 corrects the issue with those screeensavers... 
> 
> Enjoy them Colleen :)

Well, I installed the updated package and now I have a multitude of sceensavers,
many the same as in FC3, but some different.  However, although I choose
"Random" as my screensaver, I have my absolute favourite screensaver back -
"Pyro".  So, colour me happy and thanks for the tip!  :-)
Comment 15 Rex Dieter 2005-07-06 12:08:26 EDT
FYI, upstream kde bug:
http://bugs.kde.org/105748
(with patch)

Note You need to log in before you can comment on or make changes to this bug.