Bug 142749 - NX bit interferes with Java JRE 1.4.2 on intel CPUs
NX bit interferes with Java JRE 1.4.2 on intel CPUs
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ernie Petrides
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-13 15:18 EST by Nick Cabatoff
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-20 15:57:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
work-around for supporting buggy apps that don't use PROT_EXEC (1.36 KB, patch)
2004-12-13 17:44 EST, Ernie Petrides
no flags Details | Diff

  None (edit)
Description Nick Cabatoff 2004-12-13 15:18:09 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914
Firefox/0.10

Description of problem:
As per bug 123656, Sun's JDK 1.4.2 segfaults when executed unless
noexec=off is given as a boot parameter.  I opened a new bug because
the existing one refers only to AMD64, and was purportedly fixed in
kernel-smp-2.4.21-20.EL.  

Note that the problem does not occur using the uniprocessor kernel,
it's only triggered by the SMP version.

Version-Release number of selected component (if applicable):
kernel-smp-2.4.21-20.EL

How reproducible:
Always

Steps to Reproduce:
1. Install RHEL3 update 3 on an SMP machine whose cpu flags include 'nx'.
2. Install Sun's 1.4.2 JDK.
3. Run java (or jar, or jdb, etc) without arguments.
    

Actual Results:  Segfaults and dumps core.

Expected Results:  A usage message should've been printed.

Additional info:

See http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6178600
Comment 1 Ernie Petrides 2004-12-13 17:06:50 EST
Nick, this looks like a dup of bug 137464.  Could you please try
a RHEL3 U4 beta kernel from the following URL to confirm that the
problem you encountered is resolved?

  ftp://partners.redhat.com/a61d109e2483b0bf579b0b5f90a5ea8c/2.4.21-27.EL/

Thanks in advance.
Comment 2 Nick Cabatoff 2004-12-13 17:24:05 EST
Ah, I saw that bug referenced but didn't have permission to view it.  This is a
client machine though, and I'd rather not test this kernel there without at
least being able to read the changelog and the bug report.  
Comment 3 Ernie Petrides 2004-12-13 17:42:28 EST
Nick, I've added you to the cc: list of bug 137464, so you should
be able to view it now.  I'll also attach the patch that was committed
to U4 on 12/1 (in the last respin, for kernel version 2.4.21-27.EL).
Comment 4 Ernie Petrides 2004-12-13 17:44:10 EST
Created attachment 108472 [details]
work-around for supporting buggy apps that don't use PROT_EXEC
Comment 5 Nick Cabatoff 2004-12-13 18:01:50 EST
That did it.  Thanks very much on all counts.  Do you know when U4 is due out,
or if a new release of the kernel including that patch is due out anytime soon?
 I mean, I can certainly build a patched 2.4.21-20.0.1 and use that, but
obviously I'd be even happier with an official build.  
Comment 6 Ernie Petrides 2004-12-13 18:07:24 EST
Nick, by "that did it", do you mean that you've resolved that the
problem you had reported is fixed by using the -27.EL kernel?

RHEL3 U4 is scheduled for release in a week from today.
Comment 7 Nick Cabatoff 2004-12-14 10:08:39 EST
Ernie, that's correct, the -27.EL kernel does not exhibit the jdk segv problem
on intel CPUs with the NX flag.
Comment 8 Ernie Petrides 2004-12-14 15:48:50 EST
Thanks, Nick.  So, this is a dup of bug 137464, but I won't close this
as a dup since the other has access restrictions.

The fix for this problem was committed to the RHEL3 U4 patch pool on
1-Dec-2004 (in kernel version 2.4.21-27.EL).  Setting state to MODIFIED.
Comment 9 John Flanagan 2004-12-20 15:57:00 EST
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-550.html

Note You need to log in before you can comment on or make changes to this bug.