Bug 1427593 - kernel BUG at ./include/linux/scatterlist.h:140! (RIP: crypto_ccm_auth+0x489/0x630) on connect to wifi
kernel BUG at ./include/linux/scatterlist.h:140! (RIP: crypto_ccm_auth+0x489/...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 1428118 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-02-28 12:03 EST by Christian Kellner
Modified: 2017-03-04 17:51 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-03 11:45:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci -vvv (9.86 KB, text/plain)
2017-02-28 12:03 EST, Christian Kellner
no flags Details
dmesg (101.83 KB, text/plain)
2017-02-28 12:06 EST, Christian Kellner
no flags Details

  None (edit)
Description Christian Kellner 2017-02-28 12:03:45 EST
Created attachment 1258451 [details]
lspci -vvv

On a Lenovo X270, when attempting to connect to the WiFi.

[  717.718589] kernel BUG at ./include/linux/scatterlist.h:140!
[  717.718607] invalid opcode: 0000 [#1] SMP
[  717.718619] Modules linked in: ccm rfcomm fuse xt_CHECKSUM ipt_MASQUERADE nf_nat_masquerade_ipv4 tun nf_conntrack_netbios_ns nf_conntrack_broadcast xt_CT ip6t_rpfilter ip6t_REJECT nf_reject_ipv6 xt_conntrack ip_set nfnetlink ebtable_nat ebtable_broute bridge stp llc ip6table_nat nf_conntrack_ipv6 nf_defrag_ipv6 nf_nat_ipv6 ip6table_mangle ip6table_raw ip6table_security iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 nf_nat nf_conntrack libcrc32c iptable_mangle iptable_raw iptable_security ebtable_filter ebtables ip6table_filter ip6_tables cmac bnep vfat fat iTCO_wdt intel_rapl iTCO_vendor_support x86_pkg_temp_thermal mei_wdt intel_powerclamp coretemp kvm arc4 snd_soc_skl snd_hda_codec_hdmi snd_soc_skl_ipc snd_hda_codec_realtek snd_soc_sst_ipc irqbypass snd_soc_sst_dsp snd_hda_codec_generic
[  717.718853]  crct10dif_pclmul snd_hda_ext_core snd_soc_sst_match crc32_pclmul snd_soc_core snd_compress snd_pcm_dmaengine ac97_bus ghash_clmulni_intel intel_cstate intel_uncore snd_hda_intel intel_rapl_perf snd_hda_codec iwlmvm snd_hda_core snd_hwdep snd_seq mac80211 joydev snd_seq_device snd_pcm i2c_i801 snd_timer tpm_crb iwlwifi cfg80211 rtsx_pci_ms memstick shpchp 8250_pci uvcvideo mei_me videobuf2_vmalloc mei videobuf2_memops videobuf2_v4l2 videobuf2_core intel_pch_thermal videodev media btusb btrtl ucsi wmi hci_uart thinkpad_acpi btbcm btqca btintel snd soundcore bluetooth pinctrl_sunrisepoint rfkill pinctrl_intel intel_lpss_acpi intel_lpss tpm_tis tpm_tis_core acpi_pad tpm nfsd auth_rpcgss nfs_acl lockd grace sunrpc btrfs xor raid6_pq i915 rtsx_pci_sdmmc mmc_core crc32c_intel e1000e i2c_algo_bit
[  717.719092]  drm_kms_helper drm serio_raw ptp pps_core nvme nvme_core rtsx_pci video i2c_hid fjes
[  717.719126] CPU: 1 PID: 2967 Comm: cryptomgr_test Not tainted 4.11.0-0.rc0.git5.1.fc26.x86_64 #1
[  717.719151] Hardware name: LENOVO 20HNS00201/20HNS00201, BIOS R0IET30W (1.08 ) 01/16/2017
[  717.719175] task: ffff989a88bfb2c0 task.stack: ffffc031087a4000
[  717.719195] RIP: 0010:crypto_ccm_auth+0x489/0x630 [ccm]
[  717.719211] RSP: 0018:ffffc031087a79e0 EFLAGS: 00010246
[  717.719227] RAX: 0000000000000000 RBX: 1ffff806210f4f3c RCX: 0000000000000027
[  717.719248] RDX: 0000000000000017 RSI: 000000000000004f RDI: ffffc031887a7b08
[  717.719269] RBP: ffffc031087a7b60 R08: ffffc031087a7a90 R09: ffffc031087a7a90
[  717.719289] R10: 0000000000000000 R11: ffffc031087a7b16 R12: ffff989a75daae00
[  717.719309] R13: 0000000000000008 R14: ffff989a654896c8 R15: ffffc031087a7b08
[  717.719330] FS:  0000000000000000(0000) GS:ffff989aa0a00000(0000) knlGS:0000000000000000
[  717.719354] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[  717.719371] CR2: 00007f9e76961fc8 CR3: 000000022ae11000 CR4: 00000000003406e0
[  717.719392] DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
[  717.719412] DR3: 0000000000000000 DR6: 00000000fffe0ff0 DR7: 0000000000000400
[  717.719433] Call Trace:
[  717.719444]  ? get_page_from_freelist+0x73a/0xda0
[  717.719461]  ? aes_set_key_common+0x54/0x90
[  717.719475]  ? aes_set_key+0x1a/0x20
[  717.719488]  ? setkey+0x56/0xf0
[  717.719499]  ? aes_set_key+0x1a/0x20
[  717.719516]  crypto_ccm_encrypt+0x7b/0x140 [ccm]
[  717.719531]  ? crypto_ccm_encrypt+0x7b/0x140 [ccm]
[  717.719548]  __test_aead+0x7aa/0x19c0
[  717.719561]  ? rcu_read_lock_sched_held+0x79/0x80
[  717.719581]  ? crypto_skcipher_init_tfm+0x124/0x1a0
[  717.719597]  ? crypto_create_tfm+0x47/0xd0
[  717.719614]  ? crypto_acomp_scomp_free_ctx+0x30/0x30
[  717.719630]  test_aead+0x27/0xa0
[  717.719642]  alg_test_aead+0x47/0xb0
[  717.719654]  alg_test+0x1b9/0x3f0
[  717.719667]  ? __schedule+0x2c7/0xc20
[  717.719681]  ? crypto_acomp_scomp_free_ctx+0x30/0x30
[  717.719697]  cryptomgr_test+0x41/0x50
[  717.719709]  kthread+0x12c/0x150
[  717.719721]  ? kthread_create_on_node+0x60/0x60
[  717.719736]  ret_from_fork+0x31/0x40
[  717.719751] Code: 00 00 43 c7 44 03 fc 00 00 00 00 e9 aa fc ff ff b8 ff fe ff ff b9 06 00 00 00 66 89 45 b8 44 89 e8 0f c8 89 45 ba e9 cc fd ff ff <0f> 0b 0f 0b 0f 0b 0f 0b 31 f6 41 83 fe 08 4c 8d 7d b8 0f 83 ff 
[  717.719845] RIP: crypto_ccm_auth+0x489/0x630 [ccm] RSP: ffffc031087a79e0
[  717.725497] ---[ end trace 27666d50343d69b8 ]---
Comment 1 Christian Kellner 2017-02-28 12:06 EST
Created attachment 1258452 [details]
dmesg

kernel is "Linux version 4.11.0-0.rc0.git5.1.fc26.x86_64 (mockbuild@bkernel02.phx2.fedoraproject.org) (gcc version 7.0.1 20170225 (Red Hat 7.0.1-0.10) (GCC) ) #1 SMP Mon Feb 27 19:09:11 UTC 2017"
Comment 2 Laura Abbott 2017-02-28 16:11:23 EST
Fix was available upstream. I put it into the tree it should show up in tomorrow's build.
Comment 3 Laura Abbott 2017-03-01 15:59:47 EST
*** Bug 1428118 has been marked as a duplicate of this bug. ***
Comment 4 Christian Kellner 2017-03-03 10:09:18 EST
Just upgraded to kernel "4.11.0-0.rc0.git7.1.fc27.x86_64", so far that issue is gone an WiFi working as expected.
Comment 5 Laura Abbott 2017-03-03 11:45:21 EST
Thanks for testing and reporting

Note You need to log in before you can comment on or make changes to this bug.