Bug 142932 - DVI screen glitches with Radeon 9200SE
DVI screen glitches with Radeon 9200SE
Status: CLOSED DUPLICATE of bug 143872
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
3
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
: Triaged
Depends On:
Blocks: FC4Target
  Show dependency treegraph
 
Reported: 2004-12-14 21:16 EST by H. Peter Anvin
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-11 04:20:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
xorg.conf (3.96 KB, text/plain)
2004-12-14 21:17 EST, H. Peter Anvin
no flags Details
Xorg.0.llog (37.90 KB, text/plain)
2004-12-14 21:18 EST, H. Peter Anvin
no flags Details
lspci -vv output (12.45 KB, text/plain)
2004-12-14 21:19 EST, H. Peter Anvin
no flags Details

  None (edit)
Description H. Peter Anvin 2004-12-14 21:16:03 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.5)
Gecko/20041110 Firefox/1.0

Description of problem:
I have a Radeon 9200SE card attached to a Samsung SyncMaster 213T via
the DVI connector.  The screen periodically goes blank for a couple of
seconds, after which it displays "Digital" (signifiying the DVI input)
-- this is indicative of the input signal having been lost.

I have tried to figure out when it happens, and all I have been able
to conclusively determine is that I'm always moving the mouse when it
happens.  It tends to happen in "bursts"; meaning three or more
instances of the same problem in very short order.  It's reliably
reproducible on the time frame of an hour or so.

I have tried disabling the hardware cursor, and I have DRI disabled
due to bug 123511.

It it a very frustrating problem; it makes the machine almost too
annoying to use.

Version-Release number of selected component (if applicable):
xorg-x11-6.8.1-12.FC3.21

How reproducible:
Sometimes

Steps to Reproduce:
See Description

Additional info:

I will attach xorg.conf, Xorg.0.log, and lspci output to this bug.
Comment 1 H. Peter Anvin 2004-12-14 21:17:08 EST
I should add that I did *not* see this problem when I was running
stock FC2 on this system.  Either this is an X server regression, or
something else has changed.
Comment 2 H. Peter Anvin 2004-12-14 21:17:55 EST
Created attachment 108586 [details]
xorg.conf
Comment 3 H. Peter Anvin 2004-12-14 21:18:27 EST
Created attachment 108587 [details]
Xorg.0.llog
Comment 4 H. Peter Anvin 2004-12-14 21:19:22 EST
Created attachment 108588 [details]
lspci -vv output
Comment 5 Mike A. Harris 2005-01-31 22:36:07 EST
Could be related to bug #143872 perhaps?  Please upgrade to xorg-x11
from rawhide, which will be released soon as an update for FC3.

It contains numerous radeon driver and other fixes.

Please update the report with your rawhide testing results.

Thanks in advance.
Comment 6 Mike A. Harris 2005-01-31 22:37:02 EST
Setting status to "NEEDINFO", awaiting feedback of rawhide xorg-x11
testing.
Comment 7 Mike A. Harris 2005-03-01 22:39:29 EST
Does the problem persist with xorg-x11 6.8.2?  We'll be releasing
it as an update soon.  Another recommendation is to disable
renderaccel on Radeon, by putting:

 Option "NoRenderAccel"

into the device section of the xorg.conf

Please advise.
Comment 8 Mike A. Harris 2005-03-22 10:14:12 EST
Please update the bug report with your results from the testing requested
in comment #5 through 7, so we can proceed with this issue.

Thanks in advance.
Comment 9 Mike A. Harris 2005-03-22 10:40:19 EST
This might very well be a duplicate of bug #143872.  Can you review that
bug and indicate if it sounds the same as yours?

If DDC probe fails for whatever reason, it is possible the wrong resolution
gets used, and the panel is scaling it, which generally looks horrible.

Comment 10 John Stebbins 2005-04-03 12:34:17 EDT
I just upgraded to xorg-x11-6.8.2-1.FC3.13.x86_64 this morning and am
now experiencing exactly the same behavior.  I have a very similar
setup.

Shuttle SN85G4-V2 motherboard
Ati radeon 9200se
Samsung SyncMaster 213T LCD
Monitor connected to DVI output

What's a little odd is that previously I was running
xorg-x11-6.8.1-12.FC3.21.x86_64 and this problem was NOT
occuring.  Yet this is the version that this bug was
originally posted for.

I see the screen blink out then back, even when there is no
appearent activity (no mouse movement etc.).

Note that I have also been experiencing the problem noted in
bug 123511 (screen blinks while doing GL). So after reading the
note on this bug above, I disabled DRI (commented out loading
dri module in xorg.conf).

After disabling DRI, both problems have improved.  I have not
yet had an instance of the screen blanking out.
Comment 11 Mike A. Harris 2005-04-11 04:20:35 EDT

*** This bug has been marked as a duplicate of 143872 ***

Note You need to log in before you can comment on or make changes to this bug.