Bug 143872 - No 1600x1200 DVI mode from radeon driver on Radeon 9200SE
No 1600x1200 DVI mode from radeon driver on Radeon 9200SE
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
: Triaged
: 142932 (view as bug list)
Depends On:
Blocks: FC4Target
  Show dependency treegraph
 
Reported: 2004-12-30 10:08 EST by Tomas Linden
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-11 04:23:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
xorg.conf (2.94 KB, text/plain)
2004-12-30 10:11 EST, Tomas Linden
no flags Details
The Xserver log file. (50.68 KB, text/plain)
2004-12-30 10:13 EST, Tomas Linden
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 2859 None None None Never

  None (edit)
Description Tomas Linden 2004-12-30 10:08:53 EST
From Bugzilla Helper:
User-Agent: Opera/7.54 (X11; Linux i686; U)  [en]

Description of problem:
I have an Eizo Flexscan L885 1600x1200 pixel TFT display 
  http://www.eizo.com/support/discontinued/lcd/l885.asp
connected to an ASUS Radeon 9200 SE/TD 128 AGP display card:
  http://usa.asus.com/products/vga/r9200se-td/overview.htm
The graphics card sits on a dual 500 MHz PIII ASUS P2B-DS motherboard 
with 256 MB RAM. 

The radeon driver gives me a X11-display over the DVI-connection in 
1400x1050, 1280x1024, 1024x768, 800x600 and 640x480, but NOT in the 
1600x1200 mode which is the native mode of my TFT display. According 
to the monitor no signal is present on the DVI input when I switch to 
1600x1200 pixels. Over the analog VGA connection I get a viewable 
1600x1200 mode with fH 75,0 kHz and fV 60,0 Hz.

I have tried with 16 bit, no DRI but this does not give me a 
1600x1200 DVI output.

Initially I could not get any DVI-output when running system-config-
display. By adding 
  Option      "MonitorLayout" "TMDS, CRT"
to xorg.conf by hand and editing the refresh rates to be compatible 
with my monitor in digital mode, I could get to the situation 
decribed above.

The Eizo Flexscan L885 seems also to be missing from the monitor list 
used by system-config-display.

Best regards,              Tomas Linden

Version-Release number of selected component (if applicable):
xorg-x11-6.8.1-12.FC3.21

How reproducible:
Always

Steps to Reproduce:
1.run system-display-config
2.add Option      "MonitorLayout" "TMDS, CRT" to xorg.conf
3.try to use the DVI connection in the 1600x1200 mode 
    

Actual Results:  The monitor says that no signal is detected on the 
DVI-input.

Expected Results:  A 1600x1200 pixel display on the DVI-input. 

Additional info:
Comment 1 Tomas Linden 2004-12-30 10:11:17 EST
Created attachment 109185 [details]
xorg.conf

My xorg.conf file.
Comment 2 Tomas Linden 2004-12-30 10:13:40 EST
Created attachment 109186 [details]
The Xserver log file.

The Xserver log-file corresponding to my xorg.conf file.
Comment 3 Tomas Linden 2005-01-11 03:46:54 EST
I added the following option to the device section of xorg.conf
Option      "PanelSize" "1600x1200"
Comment 4 Tomas Linden 2005-01-11 04:05:00 EST
This finally gives me a signal over the DVI-connection also for the 
1600x1200 mode. Unfortunately this has severe side effects, because 
the screen blanks for one to three times for a short moment with 
random intervals. This happens sometimes so often that the mode is 
not usable, unfortunately. Without the PanelSize option the DVI-
output did not blank for the sizes less than 1600x1200.

Another side effect is that changing the resolution on the fly with 
xrandr gives strange striped borders on the left and right side of 
the display in 1400x1050. Switching to 1280x1024 and 800x600 the 
right part of the desktop is actually shown on the left edge of the 
display. Switching to 1024x768 and 640x480 works as expected.
This problem was also not present without the PanelSize option.
Comment 5 Tomas Linden 2005-01-21 05:02:11 EST
I upgraded X11 to the latest version found from the Fedora devel
to the version shown below, but I still have the random blanks of the
1600x1200 DVI signal. The same problem with xrandr and the DVI modes 
as before is still present with this new X11 version.

X Window System Version 6.8.1.902 (6.8.2 RC 2)
Release Date: 12 January 2005
X Protocol Version 11, Revision 0, Release 6.8.1.902
Build Operating System: Linux 2.4.21-27.ELsmp i686 [ELF] 
Current Operating System: Linux pc27b.hip.helsinki.fi 2.6.10-1.
741_FC3smp #1 SMP
 Thu Jan 13 16:53:16 EST 2005 i686
Build Date: 14 January 2005
Build Host: decompose.build.redhat.com
Comment 7 Mike A. Harris 2005-03-22 10:31:24 EST
Please upgrade to the xorg-x11-6.8.2 release in fc3-testing, and indicate
if the problem still exists.  If the problem persists, please file a bug
report in X.Org bugzilla at http://bugs.freedesktop.org with full details
as well, and attach your X server log and config file to the X.Org bug
report.

Once you've filed your report in X.Org bugzilla, please paste the bug URL
here and we will track the issue there as well, and review any patches that
become available for consideration in future builds.

Thanks in advance.

Setting status to "NEEDINFO", awaiting testing status update and bug URL.
Comment 8 Mike A. Harris 2005-03-22 10:41:49 EST
Bug #142932 might be related.
Comment 9 Tomas Linden 2005-03-30 05:04:58 EST
I upgraded to 
  X Window System Version 6.8.2
from the Fedora Core 3 test RPMS, but unfortunately the problems still remain, 
so I have now filed a bug at X.org
 https://bugs.freedesktop.org/show_bug.cgi?id=2859
Comment 10 Mike A. Harris 2005-04-11 04:20:37 EDT
*** Bug 142932 has been marked as a duplicate of this bug. ***
Comment 11 Mike A. Harris 2005-04-11 04:23:50 EDT
This seems to be a generic bug in the Radeon driver, unable to detect
DFP's properly.  We're now tracking this in the X.Org bugzilla.  Thanks
for reporting it upstream.

When a fix becomes available, we will review it for consideration in
future updates.

Note You need to log in before you can comment on or make changes to this bug.