Bug 142957 - When running X11 programs through ssh from FC3, it gives X protocol errors
Summary: When running X11 programs through ssh from FC3, it gives X protocol errors
Status: CLOSED DUPLICATE of bug 138617
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
(Show other bugs)
Version: 3
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-15 12:47 UTC by André Johansen
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-15 15:09:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description André Johansen 2004-12-15 12:47:45 UTC
Description of problem: 
When using ssh to connect from a FC3 host and running programs with 
X11 tunnelled, I get X protocol errors.  This does not happen when 
running ssh from another OS to the same remote. 
 
 
Version-Release number of selected component (if applicable): 
xorg-x11-6.8.1-12.FC3.21 
openssh-3.9p1-7 
emacs-21.3-17 
 
 
How reproducible: 
Always. 
 
 
Steps to Reproduce: 
1. $ ssh localhost (or any remote machine) 
2. $ emacs 
3. Perform GUI actions, e.g. click the status line at the bottom of 
the window. 
 
   
Actual results: 
X protocol error: BadWindow (invalid Window parameter) on protocol 
request 38 
 
 
Additional info: 
I've reproduced this when connecting from FC3 to several different 
OSs (RHL62, FC1, FC2, FC3). 
It does not happen when ssh'ing from any other OS than FC2. 
I'm not sure whether this is caused by X or SSH. 
This happens with other programs as well, not only Emacs.

Comment 1 Sitsofe Wheeler 2004-12-15 14:56:08 UTC
Does using ssh -Y help? If so it looks like you have been caught out by the "ssh
-X is now ssh -Y" change. (If -Y does help you can read more about the change in
bug #141515 )

Comment 2 Sitsofe Wheeler 2004-12-15 15:03:10 UTC
If you want a potentially narrower bug, emacs problems with ssh -X are covered
in bug #138617

Comment 3 André Johansen 2004-12-15 15:09:26 UTC
It certainly helped; closing this as a dupe. 
 
Adding this line to ~/.ssh/config makes life a tad easier again: 
ForwardX11Trusted=yes 
 

*** This bug has been marked as a duplicate of 138617 ***


Note You need to log in before you can comment on or make changes to this bug.