Bug 142970 - SWIG missing libraries?
SWIG missing libraries?
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: swig (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks: 141343
  Show dependency treegraph
 
Reported: 2004-12-15 10:14 EST by Ryan Skadberg
Modified: 2015-03-04 20:14 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-22 09:46:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ryan Skadberg 2004-12-15 10:14:42 EST
In trying to get Subversion to compile against the latest SWIG, I
noticed that all of the libraries that previously came with SWIG seem
to be missing.  In the FC3 RPM, there are:

/usr/lib/libswigguile.la
/usr/lib/libswigguile.so
/usr/lib/libswigguile.so.0
/usr/lib/libswigguile.so.0.0.0
/usr/lib/libswigguilescm.la
/usr/lib/libswigguilescm.so
/usr/lib/libswigguilescm.so.0
/usr/lib/libswigguilescm.so.0.0.0
/usr/lib/libswigphp4.la
/usr/lib/libswigphp4.so
/usr/lib/libswigphp4.so.0
/usr/lib/libswigphp4.so.0.0.0
etc etc

None of these exist in the 1.3.23 version that comes with Devel.  Was
this a change in SWIG or is this something wrong with the RPM?  It
seems as though subversion is looking for libswigpy.so
Comment 1 Max Bowsher 2005-01-16 04:13:59 EST
It is a change in SWIG.

Through the sequence of versions 1.3.21, 1.3.22, 1.3.23, 1.3.24, each
version of SWIG had a substantially different mechanism for supporting
bindings composed of multiple co-operating modules - like Subversion's.

The libraries referred to above no longer exist.

Since the methods to be used with 1.3.22 and 1.3.23 were removed in
1.3.24, the Subversion project has decided to not try to be compatible
with those two versions of SWIG.

However, compatibility with SWIG 1.3.24 has recently been introduced
on Subversion trunk, and will probably make it into a Subversion 1.1.x
backport release before the release of Fedora Core 4, so it would be
great if the Fedora Core SWIG package could be updated to 1.3.24.
Comment 2 Max Bowsher 2005-03-17 06:15:48 EST
Since FC4t1 contains swig 1.3.24, which suitably recent (trunk or the next 1.1.x
release) or old but suitably patched (patch attached to bug 141343) version of
Subversion can make use of, I believe this bug (certainly the Swig end of it) is
now resolved.
Comment 3 Joe Orton 2005-03-22 09:46:05 EST
Since this is just a change in how SWIG works, not a bug per se, marking this
NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.