Bug 141343 - Subversion swig bindings incompatible with swig=1.3.23
Subversion swig bindings incompatible with swig=1.3.23
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: subversion (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
:
: 147647 (view as bug list)
Depends On: 142970
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-30 11:13 EST by Ryan Skadberg
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.1.3-7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-22 09:44:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch adding swig 1.3.24 support to subversion 1.1.x (20.95 KB, patch)
2005-03-17 06:13 EST, Max Bowsher
no flags Details | Diff

  None (edit)
Description Ryan Skadberg 2004-11-30 11:13:13 EST
Description of problem:
Swig 1.3.23 currently in devel is compiled against an older version of
subversion, not the current version that comes with devel

Version-Release number of selected component (if applicable):
swig-1.3.23-1
Comment 1 Phil Knirsch 2004-12-01 08:28:14 EST
Good catch. Rebuilt today so it should be linked now against newest
version of subversion.

Read ya, Phil
Comment 2 Ryan Skadberg 2004-12-02 19:09:39 EST
Turns out I had it backwards.  Subversion is linked against the old swig:

Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package swig.i386 0:1.3.23-1 set to be updated
--> Running transaction check
--> Processing Dependency: libswigpy.so.0 for package: subversion
--> Processing Dependency: libswigpl.so.0 for package: subversion-perl
--> Finished Dependency Resolution
Error: missing dep: libswigpy.so.0 for pkg subversion
Error: missing dep: libswigpl.so.0 for pkg subversion-perl
[root@codewarrior ~]# rpm -e swif

[root@codewarrior ~]# rpm -e swig
error: Failed dependencies:
        libswigpl.so.0 is needed by (installed)
subversion-perl-1.1.1-4.i386
        libswigpy.so.0 is needed by (installed) subversion-1.1.1-4.i386
Comment 3 Ryan Skadberg 2004-12-12 15:49:14 EST
Changing the title to reflect actual bug.
Comment 4 Joe Orton 2004-12-14 07:31:06 EST
subversion does not build against the new swig unfortunately :( Some
concerted effort is needed here to port to the new release, or the
python bindings will have to be removed for a while.
Comment 5 Shane Ley 2004-12-25 22:00:55 EST
That sounds like a good plan for the immediate future, Joe. They can
always be readded when things are working properly again.
Comment 6 Joe Orton 2005-01-11 07:45:42 EST
The bindings in the Raw Hide Subversion are now disabled.  For FC4
this means doing one of:

- shipping SVN without python/perl bindings
- someone doing all the work to update SVN to the 1.3.23 swig interface
- backing down to an older swig
Comment 7 Max Bowsher 2005-01-16 07:00:41 EST
I've commented in bug 142970 (component=swig) about the development
turbulence that SWIG has recently passed through with respect to
multi-module bindings, and requested an update to 1.3.24.

Meanwhile, I will try to get the newly-added support for SWIG 1.3.24
in Subversion tested a bit more and backported to a 1.1.x release in
time for FC4.
Comment 8 Joe Orton 2005-01-17 07:32:02 EST
Thanks a lot, Max!
Comment 9 Joe Orton 2005-02-10 04:26:42 EST
*** Bug 147647 has been marked as a duplicate of this bug. ***
Comment 10 Max Bowsher 2005-03-17 06:12:18 EST
Since FC4t1 is out, and Subversion is still slowly moving towards a 1.1.4
release,  I'm attaching here the patch which adds support for swig 1.3.24, and
will be included in 1.1.4 when we eventually get there.
Comment 11 Max Bowsher 2005-03-17 06:13:12 EST
Created attachment 112082 [details]
Patch adding swig 1.3.24 support to subversion 1.1.x
Comment 12 Joe Orton 2005-03-22 09:44:16 EST
Thank you very much, Max!  1.1.3-7 in Raw Hide uses the above patch and
re-enables the swig-based bindings.  I've tested the python bindings to work fine.

Note You need to log in before you can comment on or make changes to this bug.