Bug 14301 - workstation 1.1.1-21 ftp core dumps on put nfs* when symlink present.
workstation 1.1.1-21 ftp core dumps on put nfs* when symlink present.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: krb5 (Show other bugs)
6.2
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
: 14303 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-19 20:41 EDT by Henri Schlereth
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-12 11:28:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Henri Schlereth 2000-07-19 20:41:46 EDT
This was an accidental discovery I was shipping the updated nfs-utils around to various systems and
on one I had a symlink nfs1 --> /nfs1 under a user account. put nfs* immediately core dumps with a
segmentation fault. put nfs-* works, also oddly enough mput nfs* works to where it wants to also
upload the symlink/directory. Like I side I dont knowhow much of a bug this is but I thought I report it 
anyway.
Comment 1 Bill Nottingham 2000-07-19 23:07:57 EDT
*** Bug 14303 has been marked as a duplicate of this bug. ***
Comment 2 Jeremy Katz 2000-08-08 21:55:34 EDT
The symlink seems to be a red herring.  I can trigger this also with 'put *' and
regular files.  Poke around with gdb and you see that the seg fault is in a
free, relatively obvious conclusion to come to.  Comparison to the netkit ftp
source (which has the same ancient base as the mit code) shows that the free in
cmds.c:1863 (krb5-1.2.1) isn't present in the netkit source.  Removal of this
line seems to fix the problem for me
Comment 3 Nalin Dahyabhai 2000-09-12 14:29:49 EDT
This should be fixed in krb5-1.1.1-25 and krb5-1.2.1-9.  Until Raw Hide gets
refreshed, you can grab updated packages from http://people.redhat.com/krb5/.

Note You need to log in before you can comment on or make changes to this bug.