Bug 143178 - A disturbing behaviour of "Create Launcher"
A disturbing behaviour of "Create Launcher"
Status: CLOSED DUPLICATE of bug 130859
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-16 21:45 EST by Michal Jaegermann
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2004-12-16 21:45:20 EST
Description of problem:

(Not really sure which component, or components, is responsible
for that behaviour so please adjust if needed).

After right-clicking in the middle of a screen on a "Create Launcher"
pop-up menu entry, and filling up whatever is to fill in that dialog,
one hits "OK" button and the whole thing vanishes without a trace
leaving an impression that it crashed or ignored what it was asked
to do.  Quite surprising and disconcerting.

A natural reaction is to try to redo that work again on a assumption
that this was some kind of a glitch or some wrong place was clicked
by an accident.  This turns out to be a wrong thing to attempt.

A really close examination reveals that 'ls ~/Desktop/' in a terminal
window shows all newly created *.desktop files, so they are there,
and in multiple copies if one tried many times.  Of course one
needs to know that they are somehow related to what was attempted.
OTOH they do not show up whatsoever if one tries to look in
~/Desktop using Nautilus thus strengthening an impression that all
creation  efforts were in vain.  It turns out that one has to hit
"Reload" in Nautilus while looking into that directory and then
new launchers magically pop-up on a desktop too.  Surprise!

If "Create Launcher" dialog cannot on exit kick Nautilus to wake
it up that something new is happening then it should at least
show some alert informing a user about a need of such action.

Version-Release number of selected component (if applicable):
metacity-2.8.6-2
gnome-session-2.8.0-4

How reproducible:
Always
Comment 1 Alexander Larsson 2004-12-17 04:13:42 EST

*** This bug has been marked as a duplicate of 130859 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:07:43 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.