Bug 130859 - gamin doesn't refresh anything
gamin doesn't refresh anything
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gamin (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
: 140456 141009 142686 143178 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-25 07:17 EDT by Julien Olivier
Modified: 2007-11-30 17:10 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-01 17:19:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Julien Olivier 2004-08-25 07:17:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040809

Description of problem:
I've upgraded to 08/25's rawhide, and gamin doesn't work:

 - Nothing appears on the desktop after doing "extract here" on an archive
 - The menu isn't refreshed after an RPM install
 - Deleting .recently_used doesn't empty the "recent documents" menu
 - After touch ~/Desktop/test and mkdir ~/Desktop/test2, nothing
appears on the desktop

After re-installing fam, all of that works well.

Version-Release number of selected component (if applicable):
gamin-0.0.6-1

How reproducible:
Always

Steps to Reproduce:
1.Install latest gamin
2.Try any of the tests upper
3.
    

Actual Results:  They all fail

Expected Results:  They should succeed

Additional info:

replacing gamin by fam makes all the tests succeed
Comment 1 Daniel Veillard 2004-08-25 07:29:35 EDT
You must restart the session, possibly restart the system. the
server changed location in the 0.0.5 -> 0.0.6 transition and
any application using the old shared lib won't work anymore.
Did you reboot. Can you first upgrade to 0.0.7 the latest version ?

Daniel
Comment 2 Julien Olivier 2004-08-25 07:45:35 EDT
Where can I find 0.0.7 ? It doesn't seem to be available through yum
or up2date. Could you give me a link to it please ?
Comment 3 Daniel Veillard 2004-08-25 07:48:55 EDT
Easy:

paphio:~ -> rpm -qi gamin | grep URL
URL         : http://www.gnome.org/~veillard/gamin/

Daniel

Comment 4 Julien Olivier 2004-08-25 08:02:09 EDT
OK, first thanks for the "rpm -qi" tip.

Secondly, I've just tested gamin-0.0.7 and it works well after a reboot.

Thanks for your help !
Comment 5 Daniel Veillard 2004-08-25 08:19:39 EDT
Okay, good to know,

  thanks !

Daniel
Comment 6 Julien Olivier 2004-08-26 02:59:09 EDT
Hmmm...

After using 0.0.7-1 for a while, I noticed that, from time to time, I
get the following message in one of my terminals:

end from FAM server connection

Then, nothing seems to refresh anymore, but gam_server is still
running (from ps).

Should I file a different bug for that ?
Comment 7 Daniel Veillard 2004-08-26 04:51:07 EDT
yes and indicate how to reproduce this, conditions which may 
have led to the problem, etc ...

Daniel
Comment 8 Julien Olivier 2004-08-31 06:57:15 EDT
Well, I'm sorry to say so, but I can't find any logic in gamin's
behaviour...

With gamin-0.0.8-1, I don't seem to see it crash anymore, but gamin
hardly ever refreshes my desktop folder. More over, changes in
/etc/fstab don't seem to be monitored, as new devices don't appear in
"computer" (although they are in /etc/fstab).

I'm quite lost as for why this doesn't seem to work, sorry...
Comment 9 Julien Olivier 2004-09-09 11:16:12 EDT
I was working in a terminal, and I saw the following messages appear
without any obvious reason:

end from FAM server connection
added /media/* to excludes
added /mnt/* to excludes
Adding /etc/xdg/mime/defaults.list to polling
Adding /etc/xdg/mime/mimeinfo.cache to polling
Adding /home/julien/.local/share/applications/defaults.list to polling
Adding /usr/local/share/applications/defaults.list to polling
Adding /usr/local/share/applications/mimeinfo.cache to polling
Adding /etc/xdg/mime/defaults.list to polling
Adding /etc/xdg/mime/mimeinfo.cache to polling
Adding /home/julien/.local/share/applications/defaults.list to polling
Adding /usr/local/share/applications/defaults.list to polling
Adding /usr/local/share/applications/mimeinfo.cache to polling
Adding /etc/xdg/mime/defaults.list to polling
Adding /etc/xdg/mime/mimeinfo.cache to polling
Adding /home/julien/.local/share/applications/defaults.list to polling
Adding /usr/local/share/applications/defaults.list to polling
Adding /usr/local/share/applications/mimeinfo.cache to polling
Adding /home/julien/Templates to polling
end from FAM server connection
added /media/* to excludes
added /mnt/* to excludes

At this point, gamin starting to work again, after it had stopped
working for a few minutes.

Does it help you ?

PS: it's gamin-0.9
Comment 10 Daniel Veillard 2004-09-09 13:02:46 EDT
I still don't know why it stop working for you.
It should not show those informations, they are strictly when
running in debug mode. There is something wrong but what ?
end from FAM server connection means the client or the server dropped
the connection, no idea why. So far your bug is the only one
left open for gamin or fam in bugzilla (redhat and gnome.org) !

Daniel
Comment 11 Julien Olivier 2004-09-09 17:34:48 EDT
I'm using this RPM:
http://www.gnome.org/~veillard/gamin/RPMS/RHEL3/i386/gamin-0.0.9-1.i386.rpm

Does this version have more debug info than the one inf Fedora, or is
it the same ?

Anyway, is there an option to make gamin more verbose, so that I can
investigate a bit more the problem ?
Comment 12 Daniel Veillard 2004-09-09 17:44:06 EDT
RHEL3 ? why on earth are you running a RHEL3 package on Fedora Core ????

For debugging just check the web page:
http://www.gnome.org/~veillard/gamin/debug.html

Daniel
Comment 13 Julien Olivier 2004-09-10 00:44:40 EDT
Well, I'm running the RHEL3 package, because in
http://www.gnome.org/~veillard/gamin/RPMS/FC2/i386/, there is only
v0.0.2, and I wanted to test the latest RPMs before they were in rawhide.
Comment 14 Julien Olivier 2004-09-16 15:23:31 EDT
I've now installed gamin offcial packages on both my work laptop, and
on another laptop. The problem occurs only on one of the two laptops
(running exactly the same software, with same kernel etc...).

Then, I tried installing fam on both laptops. And after a while, I
noticed that fam stops working on the same laptop where gamin used to
stop working, and not on the other one.

Could this be related to some hardware mis-functioning ? Or a kernel
issue ?
Comment 15 Julien Olivier 2004-09-16 15:30:55 EDT
Then, I tried installing Ubuntu (Debian-based) on both laptops and get
the very same results (it's fam, not gamin): it stops working on one
of the two desktops, and not on the other one.

The kernel is: 2.6.8.1-2
Comment 16 Daniel Veillard 2004-09-16 16:21:20 EDT
hum, bizarre. So it's not gamin related. The only commonalities are
the kernel dnotify interface used by both. So it seems for some reason
dnotify does not work on one of the boxes. But I really can't see
why, hardware errors would not generate just dnotify problems.
This is really puzzling. The good point for me is that it's not gamin
related which somewhat releaves me but doesn't help your problem ...

Daniel
Comment 17 Marius Andreiana 2004-10-15 06:32:46 EDT
Confirming with gamin-0.0.14-1.
Reproduce:

Create new launcher on desktop.
It appears only after pressing Ctrl+R.
Comment 18 Daniel Veillard 2004-10-15 07:07:36 EDT
"Create new launcher on desktop."

How ? Details the steps used...

Daniel
Comment 19 Marius Andreiana 2004-10-15 07:45:26 EDT
Sorry Daniel. With GUI, the only way i know is:

Right-click on desktop on a free space, choose "Create Launcher" in
pop menu.
Write command, press OK
Windows closes, new launcher doesn't appear
press Ctrl+R, it appears
Comment 20 Marius Andreiana 2004-10-15 15:55:22 EDT
Also when deleting a file in terminal, nautilus still shows it until
manually refreshing. With fam it used to remove it from file listing
after deletion from terminal.
Comment 21 Julien Olivier 2004-10-16 05:52:13 EDT
I don't know what changed but I don't have any more problems with fam
now, but I still have problems with gamin. Sorry for the confusion.
Comment 22 Quereller 2004-11-06 12:30:59 EST
There are still problems with gamin-0.0.15-1 on rawhide.
Nautilus does not display changes if you unpack something with
file-roller.
If you create a launcher on desktop it will displayed only after a
refresh.
But if you delete something on CLI it's shown immediately on nautilus.
Comment 23 Gérard Milmeister 2004-11-18 14:06:26 EST
I have similar problems, and to 0.0.17. My Iriver gets mounted
automatically, but no icons are shown in nautilus or on the desktop.
Comment 24 Christoph Noack 2004-11-26 18:02:30 EST
Same problems here by using gamin-0.0.17-1.FC3

I think since the install of Fedora Core 3 there is no refresh. My USB
disks automatically appear on the desktop.
Comment 25 Alexander Larsson 2004-12-03 04:47:53 EST
*** Bug 140456 has been marked as a duplicate of this bug. ***
Comment 26 Alexander Larsson 2004-12-12 15:15:05 EST
*** Bug 142686 has been marked as a duplicate of this bug. ***
Comment 27 Mark McLoughlin 2004-12-14 05:33:15 EST
*** Bug 141009 has been marked as a duplicate of this bug. ***
Comment 28 Øyvind Stegard 2004-12-15 16:34:53 EST
FC3/KDE3.3.2: 
* Desktop updates are not reliable, ie. they seldom happen with 
gamin (kdesktop). 
* If they happen, it's usually after the system is freshly booted or 
they only happen for every two updates. For instance, if it works at 
all, creating two new files in the desktop folder will only trigger 
an update after the second file is created, then showing both files. 
* Most of the time, it doesn't seem to work at all, though. 
 
Kernel 2.6.9-ck3,gamin-0.0.19-1FC3. 
Comment 29 Alexander Larsson 2004-12-17 04:13:44 EST
*** Bug 143178 has been marked as a duplicate of this bug. ***
Comment 30 Michal Jaegermann 2004-12-17 12:38:56 EST
re comment #28:

When doing things described in bug 143178 (it did not came to
my mind that this may be a gamin trouble)  I had more than two
newly created "launcher" files in ~/Desktop and none of them
was showing up without an explicit "Refresh" button hit in Nautilus.

Loging out of a seesion and loging back in also reflects changes
but that is way too radical "solution" for my tastes.

BTW - I was making these experiments on an x86_64 installation so
the problem is not architecture specific.
Comment 31 Jerry 2004-12-17 18:28:52 EST
I am observing this same behavior using strictly gnome desktop, so it
has nothing to do with KDE specifically.

I have to open the Desktop directory in Nautilus or refresh there and
then items show up on the Desktop.

Comment 32 Alex Duggan 2005-01-27 00:29:38 EST
Is there an updated version of gamin or a workaround available?
Comment 33 Daniel Veillard 2005-01-28 11:40:18 EST
Try the latest version 0.0.21 or CVS:
  http://www.gnome.org/~veillard/gamin/downloads.html

Daniel
Comment 34 Jerry 2005-01-28 15:57:49 EST
I can confirm that the 0.0.20 does not fix it.

I can go from source but I would rather RPM and I have never made an
RPM before.

Can we get a binary RPM on that 0.0.21 version on the download site?   
Comment 35 Alex Duggan 2005-01-28 20:15:30 EST
Daniel, 

I just rebuilt the source rpms for 0.0.21 and installed them on my
machine.  I recompiled gnome-vfs and nautilus and I still have to
manually force a refresh.  Is there anything else I need to do?
Comment 36 Alex Duggan 2005-01-28 20:19:07 EST
For those interested, the rebuilt rpms for FC3 are at
http://www.gnome.org/~aldug/gnome2/files/gamin/
Comment 37 Jerry 2005-01-28 20:57:39 EST
I have installed the 0.0.21 version and get nothing.  If at a console
I create a file with touch in the Desktop directory, it shows up.  If
I do a download of a file to the Desktop directory it does not show
up.  If I open the Desktop in a Nautalis window it does not appear
until I select view:reload fromthe menu.  The icon then appears in the
Nautalis window and on the Desktop.
Comment 38 Jeff Moe (jebba) 2005-02-21 14:00:49 EST
Previously I experienced some of the problems above, specifically icons not
appearing in the menu when new applications were installed. This looks like its
fixed in gamin-0.0.24-1.FC3.
Comment 39 Daniel Veillard 2005-03-01 17:19:48 EST
Yes this should really be fixed in 0.0.24, and regressions from
0.0.24 should be fixed in 0.0.25 which was pushed to rawhide and
available at:
   http://www.gnome.org/~veillard/gamin/sources/

Daniel
Comment 40 CoooL 2005-03-23 05:58:39 EST
I have KDE 3.3.1-2.6.FC3 and i have this problem too. My Desktop isn't refreshed
after create any file on my desktop. I can refresh it when i take file from
desktop, and i place it on desktop with konqueror. But this problem appears
middling for hour after I start my FC3. I have gamin-0.0.25-1.FC3. 

CoooL

Note You need to log in before you can comment on or make changes to this bug.