Bug 143234 - OpenOffice font rendering in UI elements broken
OpenOffice font rendering in UI elements broken
Status: CLOSED DUPLICATE of bug 136065
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
http://does-not-exist.org/ooffice-hos...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-17 12:08 EST by Thomas Roessler
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Rawhide X log file. (36.00 KB, text/plain)
2004-12-20 17:27 EST, Thomas Roessler
no flags Details
xorg.conf (3.81 KB, text/plain)
2004-12-20 17:31 EST, Thomas Roessler
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org (Old) 1424 None None None Never

  None (edit)
Description Thomas Roessler 2004-12-17 12:08:06 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
After upgrading from FC2 to FC3, menu and dialog box font display in
OpenOffice is broken, to the point of being unreadable.

See http://does-not-exist.org/ooffice-hosed.png for a sample screenshot.

Version-Release number of selected component (if applicable):
openoffice.org-1.1.2-11.5.fc3

How reproducible:
Always

Steps to Reproduce:
1. Start OpenOffice.org
2. Use menu.

Expected Results:  Readable text.

Additional info:

The same problem occurs with OpenOffice-1.1.3 as downloaded from
openoffice.org, and with the latest FC2 packages, which worked nicely
before the upgrade to FC3.  This may point to a more generic problem
with the X11/font subsystem; I'm filing the bug against OOo because I
have no idea which package is the culprit, and because OOo seems to be
the application that triggers the problem.

Platform: Thinkpad R40 with a Radeon Mobility 7500 graphics card.
Comment 1 Dan Williams 2004-12-17 12:20:44 EST
What's your "Application Font" as shown from the Main
Menu->Preferences->Fonts applet in Gnome?
Comment 2 Thomas Roessler 2004-12-17 12:55:15 EST
Sans 11; screen resolution in Preferences-Fonts-Details is set to 75
dpi to match the resolution returned by xdpyinfo.
Comment 3 Thomas Roessler 2004-12-17 15:12:18 EST
I have played around with the system a little more. The problem goes away when I
set the "NoAccel" option on the X server; this points at xorg-x11 as the
culprit. I have not yet attempted downgrading the entire X window system to an
FC2 version.

(Changing the component concerned to xorg-x11. I hope this is the appropriate
way to do this.
Comment 4 Dan Williams 2004-12-17 15:32:03 EST
Yes, its the right way to do it, but we need to reassign too. (krh: where should
these go, mharris, ssp, or you?)
Comment 5 Kristian Høgsberg 2004-12-17 17:49:53 EST
Dan, we're using xgl-maint@redhat.com for incoming X bugs, later when one of us
takes the bug we reassign it.

As for this bug, it would be nice to narrow down which specific acceleration
option causes the bug.  I'm suspecting the Render acceleration, which can be
disabled by adding:

  Option "renderaccel" "false"

to the device section in the xorg.conf config file.  Please remove the "NoAccel"
option and try this instead - thanks.
Comment 6 Thomas Roessler 2004-12-17 18:36:07 EST
Disabling the Render acceleration indeed cures the symptoms, as does a
downgrade to the 6.7.0-11 xorg packages from FC2.
Comment 7 Kristian Høgsberg 2004-12-18 01:03:34 EST
Most likely a dupe of https://bugs.freedesktop.org/show_bug.cgi?id=1424.
Comment 8 Mike A. Harris 2004-12-20 13:28:16 EST
Thomas:  xorg-x11-6.8.1.901 (6.8.2rc1) is currently in rawhide.  It
has numerous bug fixes for the radeon driver since 6.8.1 was released,
and might possibly fix this issue.  We'll be releasing 6.8.2 for
FC3 once it is officially released.  If you would be willing to test
the new rawhide X out, with render acceleration re-enabled, and report
back, that would be quite helpful to us.

Thanks in advance.

Comment 9 Mike A. Harris 2004-12-20 13:49:54 EST
Please also attach X server log and config file to bug report from
failed setup (unless you test rawhide X and it works).  Also, please
confirm wether you think the bug in comment #7 describes your issue
well.

TIA
Comment 10 Thomas Roessler 2004-12-20 17:27:31 EST
Created attachment 108922 [details]
Rawhide X log file.
Comment 11 Thomas Roessler 2004-12-20 17:31:48 EST
Created attachment 108923 [details]
xorg.conf

(The render acceleration was enabled during my test run with rawhide X. Note
that I'm using 16bpp to work around the "X freezes some time after
suspend/resume cycle" problem that used to be common with Thinkpad laptops; I
haven't bothered to verify whether or not the problem persists.)
Comment 12 Thomas Roessler 2004-12-20 17:32:41 EST
As you can guess from the attachments above, the problem persists with
rawhide X.  The bug report given in attachment 7 [details] does look like it
describes the same problem I'm also experiencing.
Comment 13 Thomas Roessler 2004-12-20 17:35:16 EST
(Make that "comment 7", not "attachment 7 [details]".)
Comment 14 Mike A. Harris 2005-03-01 22:44:07 EST

*** This bug has been marked as a duplicate of 136065 ***
Comment 15 Red Hat Bugzilla 2006-02-21 14:07:44 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.