Bug 136065 - (radeon-renderaccel) Bad font rendering in OOo UI
Bad font rendering in OOo UI
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
https://bugs.freedesktop.org/show_bug...
:
: 143234 143401 149907 (view as bug list)
Depends On:
Blocks: FC4Blocker
  Show dependency treegraph
 
Reported: 2004-10-17 06:33 EDT by Antti Andreimann
Modified: 2007-11-30 17:10 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-15 13:07:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of OOo about box with strange rendering outlined (36.78 KB, image/png)
2004-10-17 06:35 EDT, Antti Andreimann
no flags Details
About box with bad fonts (31.77 KB, image/png)
2004-11-06 15:09 EST, Jon Burgess
no flags Details

  None (edit)
Description Antti Andreimann 2004-10-17 06:33:36 EDT
Description of problem:
Font rendering produces strange results.
Please see attached screenshot for details.

Version-Release number of selected component (if applicable):
openoffice.org-1.1.2-9

How reproducible:
Always

Steps to Reproduce:
1. Open oowriter
2. Choose Help->About Openoffice.org
3. Check the word "credits" for example

Actual Results:  Some characters are garbled.

Expected Results:  Clear font rendering.
Comment 1 Antti Andreimann 2004-10-17 06:35:19 EDT
Created attachment 105347 [details]
Screenshot of OOo about box with strange rendering outlined
Comment 2 Barry K. Nathan 2004-10-17 22:46:46 EDT
Hmmm... I'm running a rawhide snapshot from the last couple of days
and I can't reproduce this. Wild guess: maybe it's locale-dependent?
What's the output of "echo $LANG" on your system?
Comment 3 Antti Andreimann 2004-10-18 04:39:27 EDT
I have latest rawhide snapshot.
System LANG=et_EE.UTF-8
For the test I ran oowriter from command line with:
LANG=en_US.UTF-8 oowriter
With my default locale OOo comes up in estonian, but the problem is
still the same.
What can I do? Is there any way to see exactly what fonts it is trying
to use?
Comment 4 Jon Burgess 2004-11-06 15:09:36 EST
Created attachment 106252 [details]
About box with bad fonts
Comment 5 Jon Burgess 2004-11-06 15:14:06 EST
I see the same problem occuring with the latest packages.
 openoffice.org-1.1.2-10.i386.rpm
 openoffice.org-libs-1.1.2-10.i386.rpm

The corrupted characters appear both in the menu system and the
documents themselves. I have added an attachment that shows my "about"
box.

My default LANG = en_GB.UTF-8
I tried running it as "LANG=en_GB oowriter", "LANG=C" etc, but it
seemed to have no effect.
Comment 6 Ian Pilcher 2005-02-25 23:15:40 EST
I believe that this may be video driver related.  I have had Fedora Core 3
installed on 4 different systems:

  - Homegrown dual-Pentium III with Matrox G200 (mga driver)
  - Homegrown VIA EPIA-M with built-in "CastelRock" graphics (via driver)
  - Homegrown Pentium III with Matrox G450 (mga driver)
  - IBM ThinkPad T30 with ATI Radeon Mobility 7500 (radeon driver)

Of these, I only see the font corruption on the ThinkPad.

I see this up through openoffice.org-1.1.3-6.5.0.fc3 on Fedora Core 3.
(The version of this bug should probably be updated.)
Comment 7 Ian Pilcher 2005-02-25 23:57:17 EST
As I suspected, I can make the font corruption go away on the ThinkPad by
adding

    Option  "Accel"     "false"

to /etc/X11/xorg.conf.

Not really a usable workaround, but perhaps this is really an X.org problem?
Comment 8 Dan Williams 2005-02-26 10:44:40 EST
Kevin: can you help direct this issue where it needs to go?  It seems to be related to ATI X.org drivers 
specifically, no other graphics chipsets are affected.  OOo makes heavy use of XRender to draw the text 
which is probably where the issue is coming from.  In any case, we'll need some X people to help 
diagnose.
Comment 9 Kevin E. Martin 2005-02-27 13:15:25 EST
Dan: There is a known issue with Render acceleration with certain Radeon cards.
 We will be disabling it by default in the next update.  In the meantime, you
can disable it by adding the following line to the "Device" section of your
xorg.conf file:

    Option "RenderAccel" "False"

This will only disable Render acceleration -- all other acceleration is still
enabled and should work fine.  When we work the remaining bugs out of the Radeon
Render accel code, we will reenable it by default.
Comment 10 Ian Pilcher 2005-02-28 02:01:18 EST
Setting "RenderAccel" to "False" does appear to fix the font rendering issues
in OpenOffice.org.  So all that's needed is the bugzilla # of the Radeon
Render problem, and this can be closed as a DUP.
Comment 11 Dan Williams 2005-02-28 12:12:41 EST
Ok, over to X.org then.
Comment 12 Dan Williams 2005-02-28 12:16:48 EST
*** Bug 136941 has been marked as a duplicate of this bug. ***
Comment 13 Dan Williams 2005-02-28 13:57:35 EST
*** Bug 149907 has been marked as a duplicate of this bug. ***
Comment 14 Dan Williams 2005-02-28 20:05:42 EST
*** Bug 143401 has been marked as a duplicate of this bug. ***
Comment 15 Mike A. Harris 2005-03-01 22:41:37 EST
Upstream bug URL:

https://bugs.freedesktop.org/show_bug.cgi?id=1424
Comment 16 Mike A. Harris 2005-03-01 22:44:28 EST
*** Bug 143234 has been marked as a duplicate of this bug. ***
Comment 17 Mike A. Harris 2005-03-01 22:46:00 EST
Adding bug alias "radeon-renderaccel" to make it easier to close
bug duplicates.
Comment 18 Mike A. Harris 2005-03-01 22:49:34 EST
* Tue Mar  1 2005 Mike A. Harris <mharris@redhat.com> 6.8.2-5
- Added
xorg-x11-6.8.2-ati-radeon-disable-broken-renderaccel-by-default.patch
  to disable render acceleration by default in the "radeon" driver, as
it is
  currently broken (#136065,136941,149907,143401,143234)
Comment 19 Mike A. Harris 2005-03-01 22:53:00 EST
Please test the rawhide 6.8.2-5.  This will be released for FC3
in the future.

Bug set to "MODIFIED" state pending testing of new rpms.

Note You need to log in before you can comment on or make changes to this bug.