Bug 1432344 - [RFE] Horizon is reporting Incorrect error for Locked VM
Summary: [RFE] Horizon is reporting Incorrect error for Locked VM
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon
Version: 9.0 (Mitaka)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: Upstream M1
: 13.0 (Queens)
Assignee: Radomir Dopieralski
QA Contact: Ido Ovadia
URL:
Whiteboard:
: 1432404 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-15 07:55 UTC by Anil Dhingra
Modified: 2020-05-14 15:45 UTC (History)
8 users (show)

Fixed In Version: python-django-horizon-13.0.0-0.20180226121410.d017fde.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:29:18 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 331874 None master: MERGED horizon: Add instance locked status on instances table (If31ae281d2782c71cd6112f3bd6228647a6130e4) 2018-02-28 13:25:03 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:30:45 UTC

Description Anil Dhingra 2017-03-15 07:55:19 UTC
Description of problem:

Horizon is reporting Incorrect error message if try to startup a VM that is LOCKED
message "Unable to start instance <instance-name>" which looks very general & no clue of what is wrong.

Command line & logs reporting correct error so need correction for horizon 

2017-03-15 13:12:47.668 4727 INFO nova.api.openstack.wsgi [req-f9d76dae-9937-447b-87b9-22ec9c5111ca 2df09339b160462d82994c4554c6a321 ceb3659d22a7467693a720a2cf62fcce - - -] HTTP exception thrown: Instance bf5ac469-6c50-43d8-aa09-7d6be59a8c2b is locked
 [root@controller ~(keystone_admin)]# nova start vm-user1
Instance bf5ac469-6c50-43d8-aa09-7d6be59a8c2b is locked (HTTP 409) (Request-ID: req-50b222ba-4e2d-43a3-b9c8-74d04219a388)
ERROR (CommandError): Unable to start the specified server(s).
Version-Release number of selected component (if applicable):


How reproducible:

always
Steps to Reproduce:
1.
2.
3.

Actual results:
horizon should report "<instance> is locked - unlock first"

Expected results:


Additional info:

Comment 1 Radomir Dopieralski 2017-03-15 09:41:37 UTC
The idea is that you check the logs to see what is wrong exactly. Horizon is supposed to be a frontend for the users of the cloud, and not a debugging tool for its operators. We can't simply forward every error message to the user, because we are never sure if it contains some technical details that the user shouldn't have access to, and because it's not translated.

Comment 2 Ganesh Kadam 2017-03-15 10:32:51 UTC
*** Bug 1432404 has been marked as a duplicate of this bug. ***

Comment 7 Radomir Dopieralski 2017-06-14 18:00:24 UTC
There is upstream work on that.

Comment 8 Radomir Dopieralski 2017-06-15 12:21:46 UTC
The upstream patch has merged.

Comment 13 errata-xmlrpc 2018-06-27 13:29:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.