Bug 1432453 - regression unzip (test/extract)
Summary: regression unzip (test/extract)
Keywords:
Status: CLOSED DUPLICATE of bug 1525636
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: unzip
Version: 7.3
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Jakub Martisko
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-15 12:20 UTC by Tru Huynh
Modified: 2018-01-30 08:55 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-01-17 08:42:55 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
CentOS 0012971 None None None 2017-03-15 12:20:23 UTC

Description Tru Huynh 2017-03-15 12:20:23 UTC
Description of problem:
unzip -t/-x failure on "large" file

Version-Release number of selected component (if applicable):
unzip-6.0-16.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1.wget ftp://ftp.dos.state.fl.us/public/doc/Quarterly/Cor/cordata.zip && sha256sum cordata.zip
2.   unzip -x cordata.zip cordata0.txt ; sha256sum cordata0.txt
3. or unzip -t cordata.zip

Actual results:
$ unzip -tv cordata.zip 
Archive:  cordata.zip
    testing: cordata0.txt             bad CRC babd3206  (should be 30142f03)
    testing: cordata1.txt             bad CRC 523b64fd  (should be c5fd87ae)
    testing: cordata2.txt             bad CRC d75f9870  (should be eae7fdd8)
    testing: cordata3.txt             bad CRC ef248dd3  (should be 30e8e892)
    testing: cordata4.txt             bad CRC 270d77e0  (should be 58137796)
    testing: cordata5.txt             bad CRC c5f9a9ed  (should be b40b3ea7)
    testing: cordata6.txt             bad CRC 52beee10  (should be 571384fe)
    testing: cordata7.txt             bad CRC 738dec2d  (should be 487ac9d5)
    testing: cordata8.txt             bad CRC 416cf7a1  (should be 38f076b0)
    testing: cordata9.txt             bad CRC 25249335  (should be 2d681da3)

$  unzip -x cordata.zip cordata0.txt
  inflating: cordata0.txt             bad CRC babd3206  (should be 30142f03)

Expected results:
no errors

Additional info:
regression, works fine on CentOS-5/6 provided unzip version.

Comment 3 Renaud Métrich 2018-01-16 13:32:04 UTC
Hi Tru,

I wanted to have a look at the issue, but the test zip doesn't exist anymore.
Do you have another file showing the issue (or can you upload the file to the BZ)?

Comment 4 Jakub Martisko 2018-01-17 08:42:55 UTC
(In reply to Renaud Métrich from comment #3)
> Hi Tru,
> 
> I wanted to have a look at the issue, but the test zip doesn't exist anymore.
> Do you have another file showing the issue (or can you upload the file to
> the BZ)?

Hi Renaud, 

there is a duplicate bug 1525636, with the same problem -> I'll close this bug as a duplicate (even though this one is older).

*** This bug has been marked as a duplicate of bug 1525636 ***

Comment 5 Renaud Métrich 2018-01-17 08:45:00 UTC
OK, I wasn't sure it was the same issue and wanted to check.

Comment 6 Tru Huynh 2018-01-29 12:24:20 UTC
ftp://ftp.dos.state.fl.us/public/doc/Quarterly/Cor/cordata.zip has been updated, not sure that the faulty file is still there. I am downloading it at the moment.

But if the root cause has been identified (as marked by "DUPLICATE"), it is probably not worth it! :P

Comment 7 Tru Huynh 2018-01-29 13:02:51 UTC
[tru@manolito tmp]$ wget ftp://ftp.dos.state.fl.us/public/doc/Quarterly/Cor/cordata.zip 
[tru@manolito tmp]$ sha256sum cordata.zip
a78c0473bdf406a256ce57122999bd7bd07b962074a999a70de30d57d7b8a304  cordata.zip
[tru@manolito tmp]$ unzip -tv cordata.zip
Archive:  cordata.zip
    testing: cordata0.txt             bad CRC 87b7e5d4  (should be 123c2a7d)
    testing: cordata1.txt             bad CRC e5a8af87  (should be d4db2c36)
    testing: cordata2.txt             bad CRC 7b5e6d2f  (should be b6265858)
    testing: cordata3.txt             bad CRC b11de195  (should be c8607054)
    testing: cordata4.txt             bad CRC 34346889  (should be a9abda9a)
    testing: cordata5.txt             bad CRC e3f1aa1f  (should be 6584db59)
    testing: cordata6.txt             bad CRC 1a226ab8  (should be 61769eca)
    testing: cordata7.txt             bad CRC 3f2c928a  (should be 8a4c1677)
    testing: cordata8.txt             bad CRC 804806c2  (should be 68293364)
    testing: cordata9.txt             bad CRC 6e1e1c43  (should be 1e670923)
At least one error was detected in cordata.zip.

Comment 8 Renaud Métrich 2018-01-30 08:55:57 UTC
Hi Tru,

I can confirm that this is exactly same BZ. I just wanted to be sure.


Note You need to log in before you can comment on or make changes to this bug.