Bug 1525636 - unzip doesn't properly extract Deflate64 files on RHEL7
Summary: unzip doesn't properly extract Deflate64 files on RHEL7
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: unzip
Version: 7.4
Hardware: All
OS: All
urgent
urgent
Target Milestone: rc
: ---
Assignee: Jakub Martisko
QA Contact: Frantisek Sumsal
URL:
Whiteboard:
: 1432453 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-12-13 18:51 UTC by Chris Cheney
Modified: 2018-04-10 19:07 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-10 19:07:39 UTC


Attachments (Terms of Use)
Example bad CRCs with Deflate64 on RHEL7 (65.73 KB, application/zip)
2017-12-13 18:51 UTC, Chris Cheney
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1039 None None None 2018-04-10 19:07:43 UTC

Description Chris Cheney 2017-12-13 18:51:06 UTC
Created attachment 1367521 [details]
Example bad CRCs with Deflate64 on RHEL7

Description of problem:

On RHEL7 unzip doesn't properly extract files compressed with Deflate64 (PKZIP version 2.1). It works fine on RHEL6. I looked through the patches but wasn't able to determine what was different that caused the problem.


Version-Release number of selected component (if applicable):

unzip-6.0-5.el6.x86_64 - good

unzip-6.0-16.el7.x86_64 - bad


How reproducible:

Use PKZIP to create an archive using Deflate64 compression. Info-Zip 'zip' in RHEL appears to not support Deflate64 for compression. I have attached an example archive.


Actual results:

RHEL7

unzip -t -v test-file.zip 
Archive:  test-file.zip
    testing: test-file.1              OK
    testing: test-file.10             bad CRC 33116a89  (should be b9f107df)
    testing: test-file.11             bad CRC 681f1464  (should be 7dcd9910)
    testing: test-file.12             bad CRC 18a00bb3  (should be 19b86783)
    testing: test-file.13             bad CRC 1a1cdeb0  (should be d05bf729)
    testing: test-file.14             bad CRC 856da232  (should be 34128307)
    testing: test-file.15             bad CRC 21cbe446  (should be e18e4b1f)
    testing: test-file.16             bad CRC 79b0e2e0  (should be 0685f733)
    testing: test-file.17             bad CRC d0721e93  (should be 10de0c60)
    testing: test-file.18             bad CRC a9ee39d9  (should be 2adc325a)
    testing: test-file.19             bad CRC afb34d56  (should be b0592893)
    testing: test-file.2              bad CRC 32ce03a6  (should be 596fbf57)
    testing: test-file.20             bad CRC 8de22823  (should be 41bf94e4)
    testing: test-file.3              bad CRC c23590e1  (should be 3ac7dd34)
    testing: test-file.4              bad CRC 405624b1  (should be 7313de02)
    testing: test-file.5              bad CRC 96a950c9  (should be 91e87f56)
    testing: test-file.6              bad CRC 4fe55800  (should be 2b3113f9)
    testing: test-file.7              bad CRC fc58c3bc  (should be 47865a6e)
    testing: test-file.8              bad CRC 156bf49e  (should be 7d61ca45)
    testing: test-file.9              bad CRC 724bd722  (should be 252aa321)
At least one error was detected in /home/ccheney/Downloads/test-file.zip.


Expected results:

RHEL6

unzip -t -v ../test-file.zip 
Archive:  test-file.zip
    testing: test-file.1              OK
    testing: test-file.10             OK
    testing: test-file.11             OK
    testing: test-file.12             OK
    testing: test-file.13             OK
    testing: test-file.14             OK
    testing: test-file.15             OK
    testing: test-file.16             OK
    testing: test-file.17             OK
    testing: test-file.18             OK
    testing: test-file.19             OK
    testing: test-file.2              OK
    testing: test-file.20             OK
    testing: test-file.3              OK
    testing: test-file.4              OK
    testing: test-file.5              OK
    testing: test-file.6              OK
    testing: test-file.7              OK
    testing: test-file.8              OK
    testing: test-file.9              OK
No errors detected in compressed data of ../test-file.zip.

Comment 13 Jakub Martisko 2018-01-17 08:42:55 UTC
*** Bug 1432453 has been marked as a duplicate of this bug. ***

Comment 19 errata-xmlrpc 2018-04-10 19:07:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1039


Note You need to log in before you can comment on or make changes to this bug.