Bug 1432879 - OSP10 -> OSP11 upgrade fails when Ironic services are enabled on a monolithic controller deployment
Summary: OSP10 -> OSP11 upgrade fails when Ironic services are enabled on a monolithic...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: rc
: 11.0 (Ocata)
Assignee: Sofer Athlan-Guyot
QA Contact: Marius Cornea
URL:
Whiteboard:
: 1431988 (view as bug list)
Depends On:
Blocks: 1394019
TreeView+ depends on / blocked
 
Reported: 2017-03-16 10:02 UTC by Marius Cornea
Modified: 2017-05-17 20:08 UTC (History)
10 users (show)

Fixed In Version: openstack-tripleo-heat-templates-6.0.0-0.10.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-17 20:08:19 UTC


Attachments (Terms of Use)
sosreport controller-0 (12.19 MB, application/x-xz)
2017-03-16 10:02 UTC, Marius Cornea
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC
OpenStack gerrit 450802 None None None 2017-03-30 10:22:30 UTC

Description Marius Cornea 2017-03-16 10:02:58 UTC
Created attachment 1263617 [details]
sosreport controller-0

Description of problem:
 OSP10 -> OSP11 upgrade fails when Ironic services are enabled on a monolithic controller deployment. The major-upgrade-composable-steps fails after 4h which is the stack update timeout which indicates that it's getting stuck. The cause for this is that during the upgrade process the openstack-nova-compute.service is trying to start on the controller nodes while the rabbitmq servers are down(pacemaker cluster is down). 

Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-6.0.0-0.20170307170102.3134785.0rc2.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Deploy OSP10 with monolithic controllers and Ironic overcloud services activated
2. Run OSP10->OSP11 upgrade

Actual results:
Deployment fails during major-upgrade-composable-steps, after 4h timeout.

Expected results:
Deployment doesn't get stuck.

Additional info:
Attaching sosreports.

Comment 1 Marius Cornea 2017-03-16 10:07:52 UTC
Note: this could be the same issue as with BZ#1431988 but I reported it as a separate one because the manifestation is different (timeout vs failure) and the topology where it shows up is different.

Comment 2 Sofer Athlan-Guyot 2017-03-24 12:22:22 UTC
Waiting to see if review in https://bugzilla.redhat.com/show_bug.cgi?id=1431988 fixes this one two.

Comment 3 Marius Cornea 2017-03-27 13:24:05 UTC
*** Bug 1431988 has been marked as a duplicate of this bug. ***

Comment 4 Sofer Athlan-Guyot 2017-03-30 10:22:31 UTC
Pointing to stable/ocata.

Comment 7 errata-xmlrpc 2017-05-17 20:08:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.