Bug 1433532 (ovnl3ha) - [RFE] [Neutron] [OVN] L3 HA
Summary: [RFE] [Neutron] [OVN] L3 HA
Keywords:
Status: CLOSED ERRATA
Alias: ovnl3ha
Product: Red Hat OpenStack
Classification: Red Hat
Component: openvswitch
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: Upstream M2
: 13.0 (Queens)
Assignee: Miguel Angel Ajo
QA Contact: Eran Kuris
URL:
Whiteboard:
: 1498109 (view as bug list)
Depends On:
Blocks: osp13ovn 1548947
TreeView+ depends on / blocked
 
Reported: 2017-03-17 23:09 UTC by Assaf Muller
Modified: 2018-06-27 13:30 UTC (History)
11 users (show)

Fixed In Version: openvswitch-2.9.0-3.el7fdb
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:29:18 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:30:45 UTC

Description Assaf Muller 2017-03-17 23:09:38 UTC
OVN L3 is currently a single point of failure and it should be highly available.

Comment 3 Miguel Angel Ajo 2017-04-24 13:15:30 UTC
Discussing up with the community
https://mail.openvswitch.org/pipermail/ovs-dev/2017-April/330597.html

And talking about limitations of the planned approach to do L3 HA Active/Standby, which are also present on VRRP or other protocols.
https://mail.openvswitch.org/pipermail/ovs-dev/2017-April/330597.html

Comment 4 Assaf Muller 2017-04-24 13:28:12 UTC
This will require OVS 2.8, pushed to OSP 13.

Comment 5 Miguel Angel Ajo 2017-07-17 15:50:27 UTC
ovn-core patches merged, now we need to work on the networking-ovn side.

Comment 7 Nir Yechiel 2017-10-03 15:00:29 UTC
An idea we just discussed was extending the northbound database with a simple boolean on the Gateway_Chassis table to reflect if it's the current master or not.  That information is already available through the southbound database by examining the Port_Binding table, but doing something in the northbound db would be a usability improvement.

One catch is that the current db schema allows you to reference a single Gateway_Chassis for multiple gateways, so maybe putting the column on Gateway_Chassis doesn't work.  Another option could be a new column on Logical_Router_Port that references a single gateway_chassis row to indicate which is the current master.

Comment 8 Nir Yechiel 2017-10-03 15:00:44 UTC
*** Bug 1498109 has been marked as a duplicate of this bug. ***

Comment 12 Eran Kuris 2018-04-10 06:34:08 UTC
verified on OSP13 puddle 2018-04-03.3
openvswitch-2.9.0-15.el7fdp.x86_64

there are some bugs. All the results updated in test run:

https://polarion.engineering.redhat.com/polarion/#/project/RHELOpenStackPlatform/testrun?id=20180327-1217

Comment 14 errata-xmlrpc 2018-06-27 13:29:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.