Bug 1498109 - [RFE] L3HA support
Summary: [RFE] L3HA support
Keywords:
Status: CLOSED DUPLICATE of bug 1433532
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-networking-ovn
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Assaf Muller
QA Contact: Ofer Blaut
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-03 13:58 UTC by Miguel Angel Ajo
Modified: 2019-09-09 13:11 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-10-03 15:00:44 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Miguel Angel Ajo 2017-10-03 13:58:09 UTC
Support for basic L3HA has landed U/S in both ovn (ovs 2.8) and neworking-ovn (Queens) mechanism driver.

But we need to polish it and add support to let the admin discover which controller is the master through the API (without looking at the SBDB manually).

Comment 1 Russell Bryant 2017-10-03 14:44:11 UTC
An idea we just discussed was extending the northbound database with a simple boolean on the Gateway_Chassis table to reflect if it's the current master or not.  That information is already available through the southbound database by examining the Port_Binding table, but doing something in the northbound db would be a usability improvement.

One catch is that the current db schema allows you to reference a single Gateway_Chassis for multiple gateways, so maybe putting the column on Gateway_Chassis doesn't work.  Another option could be a new column on Logical_Router_Port that references a single gateway_chassis row to indicate which is the current master.

Comment 2 Nir Yechiel 2017-10-03 15:00:44 UTC

*** This bug has been marked as a duplicate of bug 1433532 ***


Note You need to log in before you can comment on or make changes to this bug.