Bug 143359 - segfault dos2unix
segfault dos2unix
Status: CLOSED DUPLICATE of bug 150277
Product: Fedora
Classification: Fedora
Component: dos2unix (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-19 17:13 EST by Florian La Roche
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-13 05:02:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florian La Roche 2004-12-19 17:13:57 EST
Description of problem:

Rebuilding Pyrex within a Fedora Core development tree gives:

+ dos2unix -k -c mac CHANGES.txt ToDo.txt Tools/pyrex-mode.el
Tools/pyrex.st Doc
/About.html Doc/FAQ.html Doc/extension_types.html Doc/index.html
Doc/overview.ht
ml Doc/primes.c Doc/sharing.html Doc/special_methods.html
Demos/Makefile.nodistu
tils
dos2unix: converting file CHANGES.txt to UNIX format ...
dos2unix: converting file ToDo.txt to UNIX format ...
dos2unix: converting file Tools/pyrex-mode.el to UNIX format ...
dos2unix: converting file Tools/pyrex.st to UNIX format ...
dos2unix: converting file Doc/About.html to UNIX format ...
dos2unix: converting file Doc/FAQ.html to UNIX format ...
dos2unix: converting file Doc/extension_types.html to UNIX format ...
dos2unix: converting file Doc/index.html to UNIX format ...
dos2unix: converting file Doc/overview.html to UNIX format ...
dos2unix: converting file Doc/primes.c to UNIX format ...
dos2unix: converting file Doc/sharing.html to UNIX format ...
dos2unix: converting file Doc/special_methods.html to UNIX format ...
dos2unix: converting file Demos/Makefile.nodistutils to UNIX format ...
+ dos2unix -k -c mac Demos/callback/cheesefinder.h
Demos/callback/Makefile.nodis
tutils Demos/callback/README.txt
dos2unix: converting file Demos/callback/cheesefinder.h to UNIX format ...
dos2unix: converting file Demos/callback/Makefile.nodistutils to UNIX
format ...
dos2unix: converting file Demos/callback/README.txt to UNIX format ...
+ dos2unix -k -c mac Demos/embed/Makefile.msc
Demos/embed/Makefile.msc.static De
mos/embed/README
dos2unix: converting file Demos/embed/Makefile.msc to UNIX format ...
/var/tmp/Pyrex-0.9.2.1-3.src.rpm/rpm-tmp.88138: line 33: 14392
Segmentation faul
t      (core dumped) dos2unix -k -c mac Demos/embed/Makefile.msc
Demos/embed/Mak
efile.msc.static Demos/embed/README



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Sammy 2004-12-20 09:37:25 EST
I can confirm this too. It seems to happen for certain files only. 
Comment 2 Robert Ottenhag 2005-01-27 10:15:00 EST
I have the same problem, but testing shows that in my case the 
problem was related to the length of the path to the file, not the 
actual file contents, i.e. dos2unix <verylongpath>/myfile segfaulted, 
but doing cd <verylongpath>; dos2unix myfile works.
Comment 3 Robin Green 2005-04-12 14:52:13 EDT
Bug 150277 contains a fix for this issue.
Comment 4 Tim Waugh 2005-04-13 05:02:00 EDT
Thanks.

*** This bug has been marked as a duplicate of 150277 ***

Note You need to log in before you can comment on or make changes to this bug.