Bug 150277 - problems renaming tmpfile to outfile
problems renaming tmpfile to outfile
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dos2unix (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Ben Levenson
:
: 143359 169527 186490 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-04 02:22 EST by Stephen Beahm
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version: 3.1-24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-13 10:38:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for this problem (422 bytes, patch)
2005-09-29 08:50 EDT, Wojciech Milek
no flags Details | Diff

  None (edit)
Description Stephen Beahm 2005-03-04 02:22:01 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041020 Epiphany/1.4.4

Description of problem:
The problem is in 'dos2unix-3.1-tmppath.patch'. Memory for the null
terminator is not being allocated.

this code:
fname_len = strlen(dir) + strlen("/d2utmpXXXXXX");

should be:
fname_len = strlen(dir) + strlen("/d2utmpXXXXXX") + sizeof(char);

Version-Release number of selected component (if applicable):
dos2unix-3.1-21

How reproducible:
Sometimes

Steps to Reproduce:
1. dos2unix ./source/common/launch.h

    

Actual Results:  dos2unix: converting file ./source/common/launch.h to
UNIX format ...
dos2unix: problems renaming './source/common/d2utmptfS3dJ' to
'./source/common/launch.h'
          output file remains in './source/common/d2utmptfS3dJ'

Additional info:
Comment 1 Vladimir Kondratiev 2005-03-29 06:55:27 EST
I observe the same problem;
fix described in original report do work for me. Looks like fix is correct.
Comment 2 Tim Waugh 2005-04-13 05:02:06 EDT
*** Bug 143359 has been marked as a duplicate of this bug. ***
Comment 3 Tim Waugh 2005-04-13 10:38:15 EDT
Fixed in 3.1-24.
Comment 4 Tim Waugh 2005-09-29 08:46:33 EDT
*** Bug 169527 has been marked as a duplicate of this bug. ***
Comment 5 Wojciech Milek 2005-09-29 08:50:45 EDT
Created attachment 119415 [details]
Patch for this problem

This patch fixes allocation problem
Comment 6 Tim Waugh 2006-03-23 18:10:24 EST
*** Bug 186490 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.