Bug 1433722 - split-stack: Could not find command 'panko-dbsync' during split stack deployment
Summary: split-stack: Could not find command 'panko-dbsync' during split stack deployment
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: puppet-tripleo
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: 11.0 (Ocata)
Assignee: James Slagle
QA Contact: Gurenko Alex
URL:
Whiteboard:
Depends On:
Blocks: 1337784
TreeView+ depends on / blocked
 
Reported: 2017-03-19 14:12 UTC by Gurenko Alex
Modified: 2017-05-17 20:09 UTC (History)
11 users (show)

Fixed In Version: puppet-tripleo-6.3.0-6.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-17 20:09:25 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC
OpenStack gerrit 444338 None None None 2017-03-20 17:30:01 UTC
Launchpad 1671716 None None None 2017-03-19 14:12:10 UTC

Description Gurenko Alex 2017-03-19 14:12:11 UTC
Description of problem: copying bug for downstream to keep track of the issue. As of 2017-03-15.2 fix is not merged downstream


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. disable selinux on all nodes to avoid https://bugzilla.redhat.com/show_bug.cgi?id=1433714 bug
2. https://polarion.engineering.redhat.com/polarion/#/project/RHELOpenStackPlatform/workitem?id=RHELOSP-20870
3.

Actual results:

openstack stack failures list shows:

    Error: /Stage[main]/Panko::Db::Sync/Exec[panko-db-sync]: Failed to call refresh: Could not find command 'panko-dbsync'
    Error: /Stage[main]/Panko::Db::Sync/Exec[panko-db-sync]: Could not find command 'panko-dbsync'


Expected results:

Overcloud deployment completed successfully

Additional info:

Comment 1 Alex Schultz 2017-03-22 16:57:35 UTC
This is blocking testing for the DF split stack RFE

Comment 2 James Slagle 2017-03-23 12:42:22 UTC
this can be temporarily worked around by removing the OS::TripleO::Services::PankoApi service from all roles

Comment 3 Emilien Macchi 2017-03-23 13:02:08 UTC
Patch has been merged upstream. Waiting for the next downstream sync.

Comment 7 Gurenko Alex 2017-04-24 14:09:54 UTC
This was fixed quite few builds ago, verified on 2017-04-20.2

Comment 8 errata-xmlrpc 2017-05-17 20:09:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.