Bug 143383 - "error: too few template-parameter-lists" was shown.
"error: too few template-parameter-lists" was shown.
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: gcc (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
David Lawrence
: 143384 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2004-12-20 02:59 EST by L3support
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-12-20 03:06:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description L3support 2004-12-20 02:59:23 EST
Description of problem:

When we run g++ for complie, 
"error: too few template-parameter-lists" was shown.
( our test program is as follows -- test001.cpp )


#include <iostream>
#include <cstdio>

using namespace std;

template<class _T>
class foo
	static _T m_instance;
	typedef _T member_type;

foo<int>::member_type foo<int>::m_instance;

int main()
	return 0;

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. # g++ test001.cpp
Actual results:

error: too few template-parameter-lists

Expected results:

(1) We run g++ properly.
(2) When is corrected g++ released ? (if g++ is bug)

Additional info:

(1) When we run g++, 
    "error: too few template-parameter-lists" was not shown.
    ( g++ version: 3.2.x)

(2) The same problem is indicated.
Comment 1 Jakub Jelinek 2004-12-20 03:06:27 EST
The testcase is not valid, see the upstream bugzilla bug where it is resolved
as invalid.  g++ 3.4.x is more strict C++ than g++ 3.2.3 or 3.3.x has been.
Comment 2 Jakub Jelinek 2004-12-20 03:13:41 EST
*** Bug 143384 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.