Bug 143384 - "error: too few template-parameter-lists" was shown.
Summary: "error: too few template-parameter-lists" was shown.
Status: CLOSED DUPLICATE of bug 143383
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: gcc
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Jakub Jelinek
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-20 08:07 UTC by L3support
Modified: 2007-11-30 22:07 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2004-12-20 08:11:15 UTC


Attachments (Terms of Use)

Description L3support 2004-12-20 08:07:57 UTC
Description of problem:

When we run g++ for complie, 
"error: too few template-parameter-lists" was shown.
( our test program is as follows -- test001.cpp )

-----------------------------------------
<test001.cpp> 

#include <iostream>
#include <cstdio>

using namespace std;

template<class _T>
class foo
{
	static _T m_instance;
public:
	typedef _T member_type;
};

foo<int>::member_type foo<int>::m_instance;

int main()
{
	return 0;
}
-----------------------------------------

Version-Release number of selected component (if applicable):
gcc-c++-3.4.1-10

How reproducible:
Always

Steps to Reproduce:
1. # g++ test001.cpp
  
Actual results:

error: too few template-parameter-lists

Expected results:

(1) We run g++ properly.
(2) When is corrected g++ released ? (if g++ is bug)

Additional info:

(1) When we run g++, 
    "error: too few template-parameter-lists" was not shown.
    ( g++ version: 3.2.x)

(2) The same problem is indicated.
    http://gcc.gnu.org/bugzilla/show_bug.cgi?id=17446

Comment 1 Jakub Jelinek 2004-12-20 08:13:29 UTC

*** This bug has been marked as a duplicate of 143383 ***


Note You need to log in before you can comment on or make changes to this bug.