Bug 143388 - main firstboot window loses focus when popup dialog dismissed - kb nav issue
main firstboot window loses focus when popup dialog dismissed - kb nav issue
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: firstboot (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
David Lawrence
RHEL4U3NAK
:
: 138584 144381 (view as bug list)
Depends On:
Blocks: 181409
  Show dependency treegraph
 
Reported: 2004-12-20 05:04 EST by Wang Anli
Modified: 2007-11-30 17:07 EST (History)
4 users (show)

See Also:
Fixed In Version: RHBA-2006-0324
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-10 17:17:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Create new user (619.24 KB, image/jpeg)
2004-12-20 05:09 EST, Wang Anli
no flags Details
the patch to fix the bug (762 bytes, patch)
2005-04-14 21:57 EDT, Wang Anli
no flags Details | Diff
the patch to fix the bug (762 bytes, patch)
2005-04-14 22:00 EDT, Wang Anli
no flags Details | Diff

  None (edit)
Description Wang Anli 2004-12-20 05:04:52 EST
Description of problem:

After a system is installed with RHEL4-PRE-RC1, we reboot the system. 
We found the system will hang up if we select to continue without 
creating an non-root user account as the system recommended. 



How reproducible:


Steps to Reproduce:
1. Install a system with RHEL4-PRE-RC1
2. Reboot the system
3. System prompts to add a new system user. We don't add one and 
directly click "Next", system pops up a dialog box to warn us it is 
strong remmonended to add a new system user.(see the snapshot as 
attachment #2 [details]). we click "Continue", then system hangs up.

BTW, if we choose to add a new user with a short passwd, like "1234", 
the system will pop up a warning dialog, and after we 
click "Continue", system also hangs up.
Comment 1 Wang Anli 2004-12-20 05:09:38 EST
Created attachment 108880 [details]
Create new user 

system will hang up after we click "Continue".
Comment 2 Geoff Gustafson 2005-01-17 18:10:58 EST
What type of hardware did you do this on? I will try it on a Tiger4
and maybe Harwich.
Comment 3 Wang Anli 2005-01-18 04:37:01 EST
We found it on LangleyPR(ia32),Tiger4(ia64) and Dell PE(ia32e) on 
RHEL4-RC which is just released. 
Comment 4 Geoff Gustafson 2005-01-28 14:23:02 EST
I tried this with RHEL4-RC on a Tiger4, and did not see it. Since you see it
cross-platform, it's hard to believe it would be based on a hardware difference
between our setups or anything. This was with 1.6GHz Madisons w/ 9MB cache and
the latest 929 BIOS.

How are you installing RHEL4 exactly? What I do is use the boot.iso, then do an
NFS install over the net. I select defaults for everything, except I allow ssh
and web through the firewall. Then I do a 'default packages' install, rather
than picking custom packages.

If firstboot hangs, and then you reboot, and firstboot comes up again, does it
just hang again if you try this? Also, try going through firstboot (by adding a
user I guess). Then do this:

rm -rf /etc/sysconfig/firstboot
chkconfig --add firstboot

That will make firstboot come up again on the next reboot. Reboot and see if you
see the bug again. (This could make it much quicker to reproduce, without
reinstalling.)
Comment 5 Wang Anli 2005-01-30 22:29:54 EST
How did we do the installation: 
We use almost the same way as you. We boot the machine from boot 
images uploaded to a PXE server and then do a NFS installation.
We choose to do a full installation and disabled firewall. For 
partition, we always do manual partition, one root partition with 
almost 8G and one swap 2G. I think for others, we just use the 
default configurations.

Our testing machines are all within a private network with a gateway 
to connect to corporate intranet. 

Re-produce firstboot: 
We did as you said to re-produce the firstboot and the bug happens 
again. 

Geoff, just a reminder, we met the bug only if we _don't_ create a 
new account as it requires to. If we create a new account, the bug 
does not exists. 
Comment 6 Wang Anli 2005-02-02 04:19:52 EST
We also tried the following ways: 
1, We install the system from four CDs and do a default installation, 
only disable the firewall. We got the same situation. 
2, We connect the installed machine directly to corporate intranet, 
and make it run firstboot again, then the problem still occurs. 
3, We disconnect the installed machine from any network, and make it 
run firstboot again. We also got the problem. 

BTW, we also used Tiger4 this time. 
Comment 7 Wang Anli 2005-02-23 21:23:23 EST
We re-tested it on with the latest RC and got some more info. When we 
use graphic mode to install, the bug disappeared. And if we use text 
mode to do the installation, the bug can be re-produced. Since we use 
PXE to do installation and text mode is pre-defined in our PXE 
configuraton file everytime, so we always met this bug. And that 
seems to be the reason that we met it everytime and you can not re-
produce it. Sorry for realizing it so late. 

Comment 8 Geoff Gustafson 2005-02-28 17:57:35 EST
OK, some more feedback from An Li offline showed that the bug is really about
using the keyboard to go through firstboot, not about whether you use text-mode
or graphical install.

I tried this again, and realized the real issue. The system is not "hanging".
What is happening is that when the popup dialogs appear (such as the "you should
really make a non-root user" or the "your password is too short" dialog), the
main screen is losing focus. Thus the keyboard accelerators no longer work, and
there seems to be no way to get focus back to that window. (Alt-Tab doesn't work
for instance.)

(If you have a mouse connected when it "hangs" -- you can see that the mouse is
able to set focus back to the window and get it working again.)

It looks like firstboot needs to set focus back to the main window after each
popup is dismissed.
Comment 9 Wang Anli 2005-04-14 21:57:18 EDT
Created attachment 113206 [details]
the patch to fix the bug

property_change() function set the mode to gtk.gdk.PROP_MODE_REPLACE, it will
focus on the jumped out page and the background page will lose focus.

We've tested this patch on rhel4-u1-beta, and it works.
Comment 10 Wang Anli 2005-04-14 22:00:51 EDT
Created attachment 113207 [details]
the patch to fix the bug

property_change() function set the mode to gtk.gdk.PROP_MODE_REPLACE, it will
focus on the jumped out page and the background page will lose focus.

We've tested this patch on rhel4-u1-beta, and it works.
Comment 11 Wang Anli 2005-04-18 21:31:25 EDT
*** Bug 138584 has been marked as a duplicate of this bug. ***
Comment 12 Chris Lumens 2005-07-07 13:00:17 EDT
*** Bug 144381 has been marked as a duplicate of this bug. ***
Comment 13 Chris Lumens 2005-08-17 14:17:43 EDT
Patch also looks good for Rawhide.  Committing on there and adding bug to
proposed list.
Comment 19 Bob Johnson 2006-04-11 12:35:11 EDT
This issue is on Red Hat Engineering's list of planned work items 
for the upcoming Red Hat Enterprise Linux 4.4 release.  Engineering 
resources have been assigned and barring unforeseen circumstances, Red 
Hat intends to include this item in the 4.4 release.
Comment 24 Red Hat Bugzilla 2006-08-10 17:17:11 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0324.html

Note You need to log in before you can comment on or make changes to this bug.