Bug 143419 - Missing db4-4.3 buidl dependancy in python-2.4-2
Missing db4-4.3 buidl dependancy in python-2.4-2
Product: Fedora
Classification: Fedora
Component: python (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mihai Ibanescu
Brock Organ
: 145900 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2004-12-20 12:23 EST by Alan Sanderson
Modified: 2008-05-01 11:39 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-03-06 01:30:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Alan Sanderson 2004-12-20 12:23:20 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-AU; rv:1.7.5)
Gecko/20041213 Firefox/1.0

Description of problem:
When building python-2.4-2 with 'rpmbuild -bb --target i686
python.spec' it dies with error 'Bad exit status from
/var/tmp/rpm-tmp.7342 (%build)'
The last few lines of the build process before it dies are;

gcc -pthread -shared  Modules/_bsddb.o  -L/usr/lib -ldb-4.3  -o
/usr/bin/ld: cannot find -ldb-4.3
collect2: ld returned 1 exit status
make: *** [Modules/_bsddb.so] Error 1
error: Bad exit status from /var/tmp/rpm-tmp.7342 (%build)
[root@fc3-p4-2260 SPECS]#

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. rpmbuild -bb --target i686 python.spec with version of db4 being
2. it builds for a little while
3. die with error

Actual Results:  As above

Expected Results:  Tell me I'm missing db4 >= 4.3 at start of building
so that I can get it and install it.

Additional info:
Comment 1 Mihai Ibanescu 2004-12-20 12:56:23 EST
The spec file actually has a BuildPrereq: db4-devel which should
normally require db4.
Do you have db4-devel on your system?
Comment 2 Alan Sanderson 2004-12-27 07:02:16 EST
[root@fc3-p4-2260 ~]# rpm -q db4-devel
Comment 3 Alan Sanderson 2004-12-27 07:11:17 EST
given my output, my guess is that it should be ammended to
'BuildPrereq: db4-devel >= 4.3' or whatever the equivelent is.
Comment 4 Mihai Ibanescu 2005-01-03 09:08:33 EST
Ah I see.
Comment 5 Mihai Ibanescu 2005-01-24 15:00:19 EST
*** Bug 145900 has been marked as a duplicate of this bug. ***
Comment 6 Mihai Ibanescu 2005-04-20 15:40:49 EDT
Fixed in python 2.4.1-2 and newer, even though 'BuildPrereq: db4-devel >= 4.3'
is only half right - it won't work with db4 4.4.
Comment 7 Jeff Pitman 2005-06-10 09:32:29 EDT
FWIW, I fixed this over at pyvault using the following patch hunk:

@@ -393,11 +393,10 @@
 # Edit the variables DB and DBLIBVERto point to the db top directory
 # and the subdirectory of PORT where you built it.
-#_bsddb _bsddb.c -I$(DBINC) -L$(DBLIB) -ldb-$(DBLIBVER)
+_bsddb _bsddb.c -I$(DBINC) -L$(DBLIB) -ldb

Instead of specifying an exact version in the linkage, you can use db which is
invariantly a symlink to the latest version of db4.

This may have been done because of a conflict in compat-db, but that's removed,
only two libs and no symlinks:


I'm not sure what the pecking order is for ld, but I don't see libdb.so.3 and
friends lingering around.

Note You need to log in before you can comment on or make changes to this bug.