Bug 143423 - Default background color on some pages is grey instead of white (because of use system colors pref)
Default background color on some pages is grey instead of white (because of u...
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
: 146907 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2004-12-20 12:40 EST by Ben
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-12-20 14:21:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
yahoo does not specify background colour (80.37 KB, image/png)
2004-12-27 07:25 EST, Doncho N. Gunchev
no flags Details

External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 282141 None None None Never

  None (edit)
Description Ben 2004-12-20 12:40:40 EST
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041020 Galeon/1.3.18

In firefox-1.0-6 and mozilla-1.7.5-1:

Pages not specifying a background color should have the color in
browser.display.background_color (white). With the new Firefox and
Mozilla packages they get a color from my GTK theme instead.

Examples: about:blank or dir indexes.

Maybe the new GTK theme integration patch, because it does not appear
in Mozilla upstream?

How reproducible:

Steps to Reproduce:
1. Visit a page without a background color.
2. Notice that it's not white (possibly some gray as in 90s Netscape)
Comment 1 Christopher Aillon 2004-12-20 14:21:37 EST
NOTABUG.  This is intentional.  To restore the previous behavior, just
go to Edit>Preferences>General>Fonts and Colors and uncheck "Use
system colors"
Comment 2 Ben 2004-12-20 15:45:37 EST
Just curious, but why did the behavior of this option change? Does it
make sense to use this color for an area displaying text?

Comment 3 Doncho N. Gunchev 2004-12-23 05:56:16 EST
    There are many pages explictly setting the background color with
comments like "Workaround for broken IE 3/4". I think this is a bug,
please reopen.
Comment 4 Christopher Aillon 2004-12-23 08:29:04 EST
Explicitly setting the background will still work.  This is ONLY for
pages which do not set any color.  Can you please show me a page where
you disagree with the behavior?
Comment 5 Doncho N. Gunchev 2004-12-27 07:22:39 EST
    For example - www.yahoo.com (I was surprised too). I'll attach a
screenshot. There I selected red (the worst I could think of)
background for all pages that don't specify background colour. The
option 'Use system colours' does the same thing if I change the
default system background colour.
Comment 6 Doncho N. Gunchev 2004-12-27 07:25:39 EST
Created attachment 109135 [details]
yahoo does not specify background colour
Comment 7 Christopher Aillon 2005-02-13 15:06:00 EST
Changing resolution to RESOLVED UPSTREAM, and resummarizing to better reflect
the problem.  The pref is fine, but the color that mozilla/firefox requests from
GTK is wrong.  See upstream https://bugzilla.mozilla.org/show_bug.cgi?id=282141
Comment 8 Christopher Aillon 2005-02-13 15:08:04 EST
*** Bug 146907 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.