Bug 143476 (it_60821) - RHEL3 U4 boot fails if /tmp is a symlink to != root-filesystem
Summary: RHEL3 U4 boot fails if /tmp is a symlink to != root-filesystem
Status: CLOSED ERRATA
Alias: it_60821
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: devlabel   
(Show other bugs)
Version: 3.0
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Karel Zak
QA Contact:
URL:
Whiteboard:
Keywords: Regression
: 143608 (view as bug list)
Depends On:
Blocks: 132991
TreeView+ depends on / blocked
 
Reported: 2004-12-21 13:55 UTC by Jussi Silvennoinen
Modified: 2007-11-30 22:07 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-20 00:18:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
devlabel-tmp-not-dir.patch (490 bytes, patch)
2005-01-06 10:25 UTC, Bastien Nocera
no flags Details | Diff
don't use mktemp at all (879 bytes, patch)
2005-01-06 21:42 UTC, Bill Nottingham
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2005:121 normal SHIPPED_LIVE devlabel bug fix update 2005-05-19 04:00:00 UTC

Description Jussi Silvennoinen 2004-12-21 13:55:52 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.3)
Gecko/20040924

Description of problem:
RHEL3 U4 does not boot if /tmp is a symlink to another FS than /.
Tried on one box with U3 -> U4 update and on another with a clean U4
install, using our own kickstart which among other things, symlinks
/tmp to /var/tmp.

During the boot process, I see

Starting up RAID devices: md0 md4 md2 md3 md1
Cannot create temp file /tmp/devlabel.luyk7Al
/sbin/devlabel: line 893: $temp_proc: ambiguous redirect

Looking at the code, I see:

temp_proc=`mktemp /tmp/devlabel.XXXXXX`
echo "$proc_partitions" > $temp_proc

Removing the symlink and creating /tmp with 1777 bits allows normal
booting. Or removing devlabel-package.


Version-Release number of selected component (if applicable):
0.48.03-6

How reproducible:
Always

Steps to Reproduce:
1. Install RHEL3U4 using our own kickstart
2. Reboot the box

    

Actual Results:  Boot fails with the last messages on screen:

Starting up RAID devices: md0 md4 md2 md3 md1
Cannot create temp file /tmp/devlabel.luyk7Al
/sbin/devlabel: line 893: $temp_proc: ambiguous redirect

Expected Results:  After starting RAID devices, continue with mounting
filesystems and the rest of the boot process.


Additional info:

U3 devlabel-0.42.05 does not suffer from this.

Comment 1 Bastien Nocera 2005-01-06 10:25:02 UTC
Created attachment 109414 [details]
devlabel-tmp-not-dir.patch

Use / as the temporary directory if /tmp isn't a directory.

Comment 2 Bastien Nocera 2005-01-06 10:27:34 UTC
We could also check the retval of mktemp, this version is shorter.

Comment 3 Bill Nottingham 2005-01-06 21:42:06 UTC
Created attachment 109444 [details]
don't use mktemp at all

I prefer this, it certainly seems simpler.

Comment 4 Matt Domsch 2005-01-06 22:50:27 UTC
I agree with Bill.  Good cleanup.
I'll see if DKMS has a similar construct it can change also.

Comment 5 Bastien Nocera 2005-01-07 09:18:28 UTC
Good work Bill. It's better than my quick fix ;)

Comment 7 Tim Powers 2005-05-20 00:18:14 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-121.html


Comment 8 Bill Nottingham 2005-05-20 16:49:54 UTC
*** Bug 143608 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.