Bug 143608 - Problem with /tmp symlinked to /var/tmp and devlabel-0.48.03-6 and/or initscripts-7.31.18.EL-1, /var not mounted at time devlabel runs.
Problem with /tmp symlinked to /var/tmp and devlabel-0.48.03-6 and/or initscr...
Status: CLOSED DUPLICATE of bug 143476
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: initscripts (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-22 15:18 EST by Ted Smith
Modified: 2014-03-16 22:51 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-20 12:49:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ted Smith 2004-12-22 15:18:59 EST
Description of problem:
I just applied yesterday's mega rpm update release for RHELAS3U4 and
discovered a problem between moving from devlabel-0.42.05-2.1 to
devlabel-0.48.03-6.  Could also be related to initscripts-7.31.18.EL-1
and the order of mounting filesystems post upgrade.

Most of our systems have /tmp symlinked to /var/tmp
tmp -> ./var/tmp/

After rebooting, the system init stalls at..

Finding Module Dependencies:   [ok]
Cannot create temp file /tmp/devlabel.d0UWk8
/sbin/devlabel: line 893: $temp_proc: ambiguous redirect


Version-Release number of selected component (if applicable):
Red Hat Enterprise Linux AS release 3 (Taroon Update 3)

How reproducible:
Every time

Steps to Reproduce:
1. Create tmp -> ./var/tmp/ symlink
2. Reboot
3. system init stalls at devlabel error
4. Remove tmp symlink and create a real /tmp with 1777 
5. Reboot
6. Problem Solved (non-ideally)
  
Actual results:
See init error above

Expected results:
System should boot fine with /tmp symlinked to /var/tmp

Additional info: /etc/fstab

LABEL=/                 /                       ext3    defaults    1 1
none                    /dev/pts                devpts  gid=5,mode=620 0 0
none                    /proc                   proc    defaults     
  0 0
none                    /dev/shm                tmpfs   defaults     
  0 0
LABEL=/usr              /usr                    ext3    defaults     
  1 2
LABEL=/var              /var                    ext3    defaults     
  1 2
/dev/cciss/c0d0p3       swap                    swap    defaults     
  0 0
Comment 1 Jussi Silvennoinen 2005-05-20 02:41:19 EDT
http://rhn.redhat.com/errata/RHBA-2005-121.html
Comment 2 Bill Nottingham 2005-05-20 12:49:43 EDT

*** This bug has been marked as a duplicate of 143476 ***

Note You need to log in before you can comment on or make changes to this bug.