This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 143481 - Update of Mozilla packages leaves empty directories of prior version.
Update of Mozilla packages leaves empty directories of prior version.
Status: CLOSED DUPLICATE of bug 74160
Product: Fedora
Classification: Fedora
Component: mozilla (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-21 10:16 EST by Steve Snyder
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-31 05:47:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Steve Snyder 2004-12-21 10:16:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041220 Fedora/1.7.5-2.icc

Description of problem:
Mozilla package(s), when uninstalled in the course of an upgrade,
leave several empty directories remaining after un-installation. 
These are version-specific directories beneath the /usr/lib/,
usr/include/ and /usr/share/idl/ directories.

For example, I just updated to mozilla-1.7.5-1 (all packages for this
version: "rpm -U mozilla-1.7.5*"), after doing several prior updates.
 Now I see that the following directories exist on my system:

  /usr/share/idl/mozilla-1.6
  /usr/share/idl/mozilla-1.7
  /usr/share/idl/mozilla-1.7.2
  /usr/share/idl/mozilla-1.7.3
  /usr/share/idl/mozilla-1.7.5

All these directories are empty, with the exception of the last one
which is still in use.  The same set of empty directories can be found
beneath /usr/lib and /usr/include.

  

Version-Release number of selected component (if applicable):
mozilla-1.7.5-1

How reproducible:
Always

Steps to Reproduce:
1.Update existing mozilla packages to a new version
2.
3.
    

Actual Results:  The older version of Mozilla is uninstalled prior to
the installation of the new packages, but leaves unused directories
behind.

Expected Results:  All files and directories used the packages to be
uninstalled should be removed.

Additional info:

I stated above that this is seen on a Fedora Core #3 system, but the
problem is not an artifact of this distribution.  The same behavior is
seen with FC2 and with RHL v9.

Also, the empty directories are indeed orphans.  When queried, RedHat
Package Manager states that the empty directories are not owned by any
package.
Comment 1 Habig, Alec 2005-01-30 16:40:18 EST
I can verify it, this one's been around for as long as mozilla's been
in rpms.  Even if no 3rd party files are still present.
Comment 2 Steve Snyder 2005-03-21 11:25:29 EST
Just a note to say that this problem remains in the v1.7.6 pre-release
(mozilla-1.7.6-cvs20050313) RPM now in Rawhide.  Installation (rpm -U) of these
packages leaves the emptied directories from the prior version (mozilla-1.7.5)
in place.
Comment 3 Christopher Aillon 2005-03-31 05:47:24 EST

*** This bug has been marked as a duplicate of 74160 ***

Note You need to log in before you can comment on or make changes to this bug.