Bug 1435204 - Octavia: No octavia user created after deployment with octavia yamls
Summary: Octavia: No octavia user created after deployment with octavia yamls
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: puppet-tripleo
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: ---
Assignee: Brent Eagles
QA Contact: Alexander Stafeyev
URL:
Whiteboard:
Depends On:
Blocks: 1378993 1433523
TreeView+ depends on / blocked
 
Reported: 2017-03-23 11:48 UTC by Alexander Stafeyev
Modified: 2019-09-10 14:10 UTC (History)
9 users (show)

Fixed In Version: puppet-tripleo-6.3.0-10.el7ost.noarch
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-17 20:12:18 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC

Description Alexander Stafeyev 2017-03-23 11:48:39 UTC
Description of problem:
Octavia should have a user listed 
[root@controller-0 ~]# openstack user list
+----------------------------------+-----------------------------+
| ID                               | Name                        |
+----------------------------------+-----------------------------+
| 03d3569e3067491cbe7e75892f24b8cf | admin                       |
| 06a88d412ff448b59f54f983701a9f43 | glance                      |
| 0842c2ebeb444e52a0d6212081f932bf | nova                        |
| 191616bdbc8c40038d0ede5174e628ee | neutron                     |
| 23b1613ad57a445896e6e7876baac39d | gnocchi                     |
| 28247ea9b6c34edeb400f505eb02db8d | panko                       |
| 3b8682fe6bfd46d8b1bce6e19870387e | aodh                        |
| 3ef4366d9669451f920f54b6f6e942a3 | tempest-TrunkTest-351745715 |
| 60dae3220c3b4beeb368ef46bcacdfc0 | heat-cfn                    |
| 65bb157f7a4d42de9cc21800fd83c037 | cinder                      |
| 6e88360b5b8144bbaf3085dc304ae812 | ceilometer                  |
| 72a8333c9bd54db1b4af3095b3df3ea6 | heat                        |
| 79f34968fe394c809fbcfc5cf6d4f257 | placement                   |
| 8075a3c23b424c499f450501ccb512bc | swift                       |
| 81ae78c488be4e6cbc0e1e706c108ec7 | demo                        |
| b2ed549c1e22434e843de883832c315b | tempest-TrunkTest-807844836 |
| d7282ee1112d4c8b8e02147751bd40bc | alt_demo                    |
+----------------------------------+-----------------------------+
 


Version-Release number of selected component (if applicable):

rhos 11 
How reproducible:
100%

Steps to Reproduce:
1. Deploy ospd 11 with octavia 
2. list users - openstack user list 
3.

Actual results:
No octavia user created 

Expected results:

We should see Octavia user 
Additional info:

Comment 1 Brent Eagles 2017-03-30 15:15:44 UTC
The cause is known. There is a piece missing from the puppet-tripleo keystone profile.

Comment 3 Alexander Stafeyev 2017-04-18 13:07:01 UTC
[stack@undercloud-0 ~]$ openstack user list
+----------------------------------+------------+
| ID                               | Name       |
+----------------------------------+------------+
| 1b0aef164713432d957aa80bc7d311c1 | neutron    |
| 3e9a6f11b2934e50b20b993466f1d1ae | glance     |
| 4b107afe818c4a48ac3ed42d42f9e176 | placement  |
| 4c41dda95579434f8598d1ccb6a890f1 | nova       |
| 51a94f2e90e24727aa4a2f242f196ca6 | panko      |
| 580be7c423ce44f68c6ea81112f10a85 | cinder     |
| 5f20f5c2244e4d26a06f7564ceced136 | heat-cfn   |
| 78a7b7a69caf49a4b8c182d2ae002f88 | gnocchi    |
| 811678b3edd84eb08360e93ff5c4ce30 | admin      |
| 92a30f2ba83741d9b5d990a9cf8263e0 | ceilometer |
| 99e1a9a85e624e289384b0537e228162 | octavia    |
| a0388e11a62e4048a926d2dea679a64b | aodh       |
| a4b131d27be94a57bbf1163d1815f4c7 | heat       |
| c97e65a6bcf440efb27ac86b316bee40 | swift      |
+----------------------------------+------------+


[stack@undercloud-0 ~]$ rpm -qa | grep triple
openstack-tripleo-validations-5.4.0-8.el7ost.noarch
openstack-tripleo-puppet-elements-6.0.0-1.el7ost.noarch
openstack-tripleo-image-elements-6.0.0-2.el7ost.noarch
python-tripleoclient-6.1.0-6.el7ost.noarch
openstack-tripleo-heat-templates-6.0.0-5.el7ost.noarch
puppet-tripleo-6.3.0-10.el7ost.noarch
openstack-tripleo-common-6.0.0-7.el7ost.noarch
openstack-tripleo-ui-3.1.0-9.el7ost.noarch


The fixed in version my version are not matching - this gap is the only one that prevents verification. 

THE FIX IS THERE - but why the versions are not matching ?

Comment 4 Brent Eagles 2017-04-18 13:26:58 UTC
We pulled the "fixed in version" from a list of candidate builds. I've confirmed that the relevant patch is included in the SRPM for 6.3.0-10.

Comment 5 Assaf Muller 2017-05-17 16:59:51 UTC
Reported and fixed on internal builds without an external release, marking doctext as not necessary.

Comment 6 errata-xmlrpc 2017-05-17 20:12:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.