Bug 1378993 - [RFE] [Neutron] [OSP-director] Support deploying Octavia in the overcloud
Summary: [RFE] [Neutron] [OSP-director] Support deploying Octavia in the overcloud
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: async
: 11.0 (Ocata)
Assignee: Brent Eagles
QA Contact: Alexander Stafeyev
URL: https://blueprints.launchpad.net/trip...
Whiteboard: upstream_milestone_ocata-rc1 upstream...
: 1385343 (view as bug list)
Depends On: 1305800 1417670 1433727 1433728 1433729 1434901 1434904 1434919 1435204 1435266 1439898 1542065
Blocks: 1429309
TreeView+ depends on / blocked
 
Reported: 2016-09-23 19:59 UTC by Brent Eagles
Modified: 2020-08-13 08:36 UTC (History)
17 users (show)

Fixed In Version: openstack-tripleo-heat-templates-6.0.0-0.20170307170102.3134785.0rc2.el7ost.noarch.rpm
Doc Type: Enhancement
Doc Text:
This enhancement provides configuration for OpenStack Load Balancing as a Service (octavia) through the Red Hat OpenStack Platform director.
Clone Of:
Environment:
Last Closed: 2017-06-15 16:55:53 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1475 0 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 director Bug Fix Advisory 2017-06-15 20:55:23 UTC

Description Brent Eagles 2016-09-23 19:59:12 UTC
Octavia is a Load Balancing as a Service implementation that is currently the reference backend for Neutron LBaaS. Considering some of the details of deploying Octavia, supporting it in OSP-d is vital to providing access for customers. 

The upstream blueprint: 

   https://blueprints.launchpad.net/tripleo/+spec/octavia-support

Comment 1 Nir Yechiel 2016-10-16 11:29:31 UTC
*** Bug 1385343 has been marked as a duplicate of this bug. ***

Comment 7 Nir Yechiel 2017-02-02 17:39:10 UTC
There are currently three patches pending, all targeted to ocata-rc-1 upstream: https://review.openstack.org/#/q/status:open++branch:master+topic:bp/octavia-service-integration

Comment 9 Nir Yechiel 2017-02-16 15:23:53 UTC
This bug tracks support for phase I of the TripleO integration as described in https://blueprints.launchpad.net/tripleo/+spec/octavia-service-integration

Comment 20 errata-xmlrpc 2017-06-15 16:55:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1475


Note You need to log in before you can comment on or make changes to this bug.