Bug 1435754 - cant install nodejs-libxmljs from epel on RHEL 7
Summary: cant install nodejs-libxmljs from epel on RHEL 7
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: nodejs-libxmljs
Version: epel7
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Nobody's working on this, feel free to take it
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1668929 (view as bug list)
Depends On:
Blocks: EPEL7FailsToInstall
TreeView+ depends on / blocked
 
Reported: 2017-03-24 16:41 UTC by John Roman
Modified: 2020-11-05 09:31 UTC (History)
2 users (show)

Fixed In Version: nodejs-libxmljs-0.18.7-6.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-18 01:07:17 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description John Roman 2017-03-24 16:41:01 UTC
Description of problem:
nodejs-libxmljs will not install from EPEL on RHEL7

Version-Release number of selected component (if applicable):


How reproducible:
very

Steps to Reproduce:
1.yum install nodejs-libxmljs
2.
3.

Actual results:
failed

Expected results:
success.

Additional info:
[root@redacted]# yum install nodejs-libxmljs
Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-manager
Resolving Dependencies
--> Running transaction check
---> Package nodejs-libxmljs.x86_64 0:0.9.0-1.el7 will be installed
--> Processing Dependency: nodejs(v8-abi) = 3.14 for package: nodejs-libxmljs-0.9.0-1.el7.x86_64
--> Processing Dependency: nodejs(abi) = 0.10 for package: nodejs-libxmljs-0.9.0-1.el7.x86_64
--> Processing Dependency: nodejs(engine) >= 0.4.7 for package: nodejs-libxmljs-0.9.0-1.el7.x86_64
--> Processing Dependency: npm(bindings) for package: nodejs-libxmljs-0.9.0-1.el7.x86_64
--> Running transaction check
---> Package nodejs.x86_64 1:6.9.4-2.el7 will be installed
--> Processing Dependency: npm = 1:3.10.10-1.6.9.4.2.el7 for package: 1:nodejs-6.9.4-2.el7.x86_64
--> Processing Dependency: libuv >= 1:1.9.1 for package: 1:nodejs-6.9.4-2.el7.x86_64
--> Processing Dependency: libuv.so.1()(64bit) for package: 1:nodejs-6.9.4-2.el7.x86_64
---> Package nodejs-bindings.noarch 0:1.2.0-1.el7 will be installed
---> Package nodejs-libxmljs.x86_64 0:0.9.0-1.el7 will be installed
--> Processing Dependency: nodejs(v8-abi) = 3.14 for package: nodejs-libxmljs-0.9.0-1.el7.x86_64
--> Processing Dependency: nodejs(abi) = 0.10 for package: nodejs-libxmljs-0.9.0-1.el7.x86_64
--> Running transaction check
---> Package libuv.x86_64 1:1.10.2-1.el7 will be installed
---> Package nodejs-libxmljs.x86_64 0:0.9.0-1.el7 will be installed
--> Processing Dependency: nodejs(v8-abi) = 3.14 for package: nodejs-libxmljs-0.9.0-1.el7.x86_64
--> Processing Dependency: nodejs(abi) = 0.10 for package: nodejs-libxmljs-0.9.0-1.el7.x86_64
---> Package npm.x86_64 1:3.10.10-1.6.9.4.2.el7 will be installed
--> Finished Dependency Resolution
--> Finding unneeded leftover dependencies
Found and removing 0 unneeded dependencies
Error: Package: nodejs-libxmljs-0.9.0-1.el7.x86_64 (epel)
           Requires: nodejs(v8-abi) = 3.14
           Installing: 1:nodejs-6.9.4-2.el7.x86_64 (epel)
               nodejs(v8-abi) = 5.1
Error: Package: nodejs-libxmljs-0.9.0-1.el7.x86_64 (epel)
           Requires: nodejs(v8-abi) = 3.14
           Available: 1:nodejs-6.9.4-2.el7.x86_64 (epel)
               nodejs(v8-abi) = 5.1
Error: Package: nodejs-libxmljs-0.9.0-1.el7.x86_64 (epel)
           Requires: nodejs(abi) = 0.10
           Installing: 1:nodejs-6.9.4-2.el7.x86_64 (epel)
               nodejs(abi) = 6.9
Error: Package: nodejs-libxmljs-0.9.0-1.el7.x86_64 (epel)
           Requires: nodejs(abi) = 0.10
           Available: 1:nodejs-6.9.4-2.el7.x86_64 (epel)
               nodejs(abi) = 6.9
**********************************************************************
yum can be configured to try to resolve such errors by temporarily enabling
disabled repos and searching for missing dependencies.
To enable this functionality please set 'notify_only=0' in /etc/yum/pluginconf.d/search-disabled-repos.conf
**********************************************************************

Error: Package: nodejs-libxmljs-0.9.0-1.el7.x86_64 (epel)
           Requires: nodejs(v8-abi) = 3.14
           Installing: 1:nodejs-6.9.4-2.el7.x86_64 (epel)
               nodejs(v8-abi) = 5.1
Error: Package: nodejs-libxmljs-0.9.0-1.el7.x86_64 (epel)
           Requires: nodejs(v8-abi) = 3.14
           Available: 1:nodejs-6.9.4-2.el7.x86_64 (epel)
               nodejs(v8-abi) = 5.1
Error: Package: nodejs-libxmljs-0.9.0-1.el7.x86_64 (epel)
           Requires: nodejs(abi) = 0.10
           Installing: 1:nodejs-6.9.4-2.el7.x86_64 (epel)
               nodejs(abi) = 6.9
Error: Package: nodejs-libxmljs-0.9.0-1.el7.x86_64 (epel)
           Requires: nodejs(abi) = 0.10
           Available: 1:nodejs-6.9.4-2.el7.x86_64 (epel)
               nodejs(abi) = 6.9
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Comment 1 Troy Dawson 2019-01-31 23:54:01 UTC
*** Bug 1668929 has been marked as a duplicate of this bug. ***

Comment 2 Fedora Update System 2019-02-01 16:16:46 UTC
nodejs-libxmljs-0.18.7-6.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-51bd8e5cd0

Comment 3 Fedora Update System 2019-02-02 00:48:46 UTC
nodejs-libxmljs-0.18.7-6.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-51bd8e5cd0

Comment 4 Fedora Update System 2019-02-18 01:07:17 UTC
nodejs-libxmljs-0.18.7-6.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.